[SOLVED] Failing to setup Android sdk environment

I am trying to setup an android environment to do some tests on android, and following the docs :


After I follow the procedure I got this error :
java.io.FileNotFoundException: C:\projects\java\jm3_games\testandroid\mobile\build.xml
I did notice that when I enabled the android Deployment, it created the mobile dir, but its empty.

Also, I dont know, but I get confused with the line :
“Make sure you have installed the Android Project Support into the jMonkeyEngine SDK.”
That is exactly what I am trying to do and I was hopping this docs has this information, seens it dosent.

I am using old good Jm3 yet, but just download the last android sdk version, mabe this is the problem ?
Should I do it in jm3.1 ?

I would:
a0) install the android sdk and download what you need. I use 4.2 (or 4.2.2 or something).
a) go back to non-android (check the compile on save checkbox, disable android deployment and set configuration to default config
b) clean and build
c) make sure you have installed all the plugins with names such as android, netbeans android, that kind of stuff
d) go to tools/android sdk manager and do what is asked there.
f) uncheck compile on save and set configuration to android
g) click the "run android target configuration utility
h) check enable android development and choose an android target
i) check that the important files are now appearing and enter MainActivity (should have plenty errors)
j) clean and build, which should correct all the errors displayed in the MainActivity file.

Maybe I got some order wrong there, but that’s the main zest of it. Works for me on 3.0 and 3.1.

1 Like

I tried that, its working now, but I think the trick was to restart the ide right away when you check the android development, if I dont do it it gets that error…

Man thank you, doing everything in the exact same order got my problem solve i think!

Thank you, that post made my day :).