[SOLVED] Git without Git Bash

Is there a way to set Git user.name and user.email for an external editor without installing Git Bash on a windows system?

Netbeans doesn’t require it, can just clone and start using Git.

I’m not sure I understand the question. Do you already have a git client?

…obviously you won’t be able to use git without a git client. I’ve personally never used git bash, though.

Yes, but the damdest thing is I cant edit the .gitconfig on windows because the bastards removed edit from 64 bit system.
I cant use the built in git without setting the user.name and user.email and I don’t want to install yet another program just to use the other program that needs 2 other programs to run.

Edit:.gitconfig only is visible from command prompt is whats a real pisser.

You can generally configure git settings using git.

Is that what you are asking about?

From a google search for “git set username”…

git config --global user.name “Mona Lisa”

I can only do that if I install Git Bash. I just want to edit the .gitconfig and manually add the info rather than installing another conflict prone program into my computer.

On Linux you can just use VI but windows removed all editing from the command prompt unless theres something I am not aware of.

If you don’t have a git client then what git client are you using?

How are you running git clone if you don’t have some kind of git client? And if you can run git clone then you set the user name, etc. through that git client.

I have a client built into the editor but they require you to set user.name and user.email externally first in order for it to work. They provide no means of editing the config.

NetBeans works without this problem though.

I brought this up on their website but all I got back was chirping crickets…

So, they require you to set something externally to configure something built into their editor? Delete the editor, I guess because it sounds like a piece of excrement…

But anyway… is it a file permission problem then? I’m only running windows 7 and I can still edit stuff in my user directory (using notepad if I have to).

Yes, that’s what I am about to do.

.gitconfig is only visible from command prompt. I would have associate it with notepad or something from the command prompt and risk frying the file for good.

Delete the editor sounds like the best approach. To bad since it had the potential to make wiki editing a breeze. Just to much a pain in the ass to get it up and running.

Atom editor.

I’m still not sure I understand… if you can only see the .gitconfig file from the command prompt then what stops you from running “notepad .gitconfig” from the command prompt?

Why do you need to associate it? I’ve never done that and I edit files from the command line all the time.

It wont open it.

.gitconfig is only visible from command line prompt.
Nothing opens it.
Nothing on the system to open it short of installing.

I hate Microsoft.

So, typing:
notepad .gitconfig
…on the command line:

  1. does nothing
  2. presents an error
  3. opens the editor but without anything in it
  4. blows up your computer?

Lots of different “won’t open it”… but I’ve never had that problem. Perhaps even more reasons not to upgrade.

I just got it to open using netbeans. Only thing that even sees it. Its empty. Ill see what happens when edit it.

Note: if it’s empty and you just want to add stuff then you can do that from the command line also:

echo Thing you want to add >> .gitconfig

It worked.

It was opening the file from command prompt but was empty. I thought it was just opening up empty default doc. Sorry for trouble.