[SOLVED] Gradle issue with JME versions

I want to run my game against jme 3.3.0-alpha1 to verify a regression. So my gradle is:

jmeVersion = "3.3.0-alpha1"
compile "org.jmonkeyengine:jme3-core:$jmeVersion"
compile "org.jmonkeyengine:jme3-desktop:$jmeVersion"
compile "org.jmonkeyengine:jme3-lwjgl:$jmeVersion"

but with gradle test dependencies I get

compile - Dependencies for source set 'main' (deprecated, use 'implementation' instead).
+--- org.jmonkeyengine:jme3-core:3.2.1 -> 3.4.0-beta4
+--- org.jmonkeyengine:jme3-desktop:3.2.1 -> 3.4.0-beta4
|    \--- org.jmonkeyengine:jme3-core:3.4.0-beta4

…and indeed the game runs with 3.4.0-beta4 instead. How can I achieve my goal? Thanks!

You truncated the “gradle test dependencies” output before it got to the interesting part.

Are you using some (non-JME) libraries that depend on jme3-core:3.2.1 and jme3-core:3.4.0-beta4?

+--- com.pesegato:MonkeySheet:latest.integration -> 0.6.0-SNAPSHOT
|    +--- org.jmonkeyengine:jme3-core:[3.1,) -> 3.4.0-beta4

I feel so dumb… I wrote that library myself :sweat_smile: