[Solved] Gui node lighting not working on Intel graphics


I’m developing an octree editor in my laptop using Jme3.1 Alpha.
My laptop has a discrete Nvidia graphics card and an Intel graphics chip embedded in the cpu.
In Windows, I can choose to use one graphics chip or the other for each program I launch.

So, in my application I want the user to see the current material used in the editor by means of a small rotating box on the top left of the screen. The box is attached to the gui node as well as a “sun” light. The code works perfectly when using the Nvidia graphics chip:

but when I launch it using the Intel graphics chip, the box is not lit:

Unshaded materials are rendered properly with both graphics cards, the only problem I have is with materials based on Lighting.j3md.
Should I blame the Intel graphics driver?

Does it have a normal map? Did you generate tangents for it?

That’s the only thing I can think that could normally produce different results on different cards. Else, yeah, an intel driver bug.

Right, I was missing a call to TangentBinormalGenerator.generate(mesh) on the Box mesh.
I got fooled by the fact that with the Nvidia graphics it worked anyway.
Rookie mistake.
Thanks for the help :slight_smile:

Well, it was still wrong… it was just not black. Sometimes on nvidia you get lucky and the views happen to still have textures but the normal maps would still have been wrong.