[Solved] Having problems installing from Github

Hiya guys…

Yeah… I’m smacking my brain into a fine pulp on this one… :sweat:

I want to try out the github repository, and build the sdk (mainly because I wanna see the cool new stuff, too!) and um… well… It’s not working?

I am not well versed in ant/build.xml, nor gradle. It appears that gradle requires a jdk, and that gradlew.bat is the one to “click on”… well, it shows the test launcher at any rate… at least I get to see the cool tests n stuff.

I really want to see the sdk up in action though… so, I’ve got the vid where I’m playing with the stuff… Am I missing anything? Is there some project property that I have to set to get this to work?

I know that the general gist of it is to Clean and Build the top level project (I think that it is the “sdk” module suite project…) and then “package as zip distributable”… But, it’s getting blocked on the “Clean and Build”. It doesn’t build the various library jars so that it can “distill them”.

Game On,
Charles

Curious: how else would gradle build java apps without a JDK installed?

…and I hope the “quotes” around “click on” means that you are actually running it from the command line. (Not sure why not just say that.)

gradlew build

…but for the SDK to build you have to set some build.properties I’m not sure what those are, though, as I haven’t tried to build the SDK yet.

haha, nope, I am actually clicking on it with my mouse… In Windows, that’s the same as opening a command line window with the current directory as the working directory and running the item with no command line arguments. The downside is that console windows close automatically if there are errors. So… great for running perfectly functional .bat files… bad for debugging on problem situations… but yeah, I totally went derp when I saw the “I needs the JDK, foo’!” error message that first time.

Yeah, it’s like Microsoft is embarrased by anything command line… and tries very hard to “pooh pooh” it’s usage.

I’ll give that command line thingy a shot right quick… lessee here…

gradlew build

…yeppers… That was what I was derping on… hehe… eh… hehehe

Thanks Paul! I’ll get back to rampaging around on my vid making and playing with the new toys that are oh-so-much-fun to play with. It compiled and now I will try installing it… and open up other cans of worms to dump on myself. :laughing:

Of course I know what double clicking on a batch file does… I just never saw a developer try that with a command line build tool before.