[Solved] Ignoring keyboard input

Hi there. This engine seems very promising. Unfortunately though, I am not without problems or criticisms. Firstly, there is quite a lack of jME2 specific support, even though it is being recommended by the developers above jME1, which is covered in most of the wiki (including installation instructions).

So after I trudged around for a while, I finally got jME2 set up in Eclipse. I went to run some demos per the instructions in the Eclipse install guide. They ran, but the only way I could quit was Alt+F4. I noticed that there were some demos that could take keyboard input. Like, "F4 to toggle stats". Of course, that did nothing. I ran an effects demo that had even more options, and still nothing.

It seems that keyboard input is being ignored. Can anyone help me out? I'm running Ubuntu Linux 8.04, and using Sun Java 6 JRE.

Any and all help would be greatly appreciated. :slight_smile:

Although a very hardy linux supporter (no pun intended) I think it's probably the Ubuntu, but do make sure you have the window selected when you're typing.

Lol@pun. :slight_smile:

As far as I know, the window is selected. Mouse movement, as in looking around, is working perfectly fine. But the keyboard keys, they do nothing.

it works on my Ubuntu 8.04 with Sun Java 6 JRE. So no idea what could be wrong.

TiZ said:
But the keyboard keys, they do nothing.

What about the goggles?
Trussell said:

TiZ said:
But the keyboard keys, they do nothing.

What about the goggles?

They work perfectly.

I found a little bit of info that might possibly pertain to my problem. At least one person having problems like in the below thread was using a laptop. I am too, a Gateway MT6452. Probably should have said that before.


And I'll c/p the enlightening post:

Well I wasn't exactly overwhelmed there with responses...

But we figured it out.   The "getting started" post shows an example with the mouse controller, where only the first mouse controller is polled.   We had done the same thing with the keyboard controller, and this works on most computers.   But on some systems the first keyboard controller is not the correct controller, and no events come through.

Now we're checking all controllers, and things are working fine.   We may make a change to detect which controller is active, and stop polling the other keyboard controllers.

Not saying this is definitely the problem, but it might help.

Triple post. Thanks for not breaking my c-c-combo. :slight_smile:

Anyways, I paid a visit to the #lwjgl channel just now, and luckily, someone was there who had the exact same problem and exact same solution as me.

If you have SCIM, that little keyboard icon that sits in your system tray and lets you switch keyboard layouts and input methods, right click it and exit. Input will magically start working.

Thanks to #jme for all their efforts. Community is definitely a high strong point here. :slight_smile: