[SOLVED] java.lang.IllegalArgumentException: for uniform m_BoneMatrices: value cannot be null

Can anyone explain to me what this error message implies? I save a Node I’ve generated to a j3o file, via BinaryExporter, and then load it again. It loads fine but when I attach it to the root Node this error comes up. The problem is probably somewhere in my code before I save the Node, but it would really help me work out the problem better if I understood what this meant.

EDIT: To clarify, the Node displays fine before I save it and load it again.

SOLUTION: Using JME 1.3.1-beta2 instead of 1.3.1-beta1 fixed it.

java.lang.IllegalArgumentException: for uniform m_BoneMatrices: value cannot be null
	at com.jme3.shader.Uniform.setValue(Uniform.java:210)
	at com.jme3.material.Material.updateShaderMaterialParameters(Material.java:804)
	at com.jme3.material.Material.render(Material.java:960)
	at com.jme3.renderer.RenderManager.renderGeometry(RenderManager.java:616)
	at com.jme3.renderer.queue.RenderQueue.renderGeometryList(RenderQueue.java:266)
	at com.jme3.renderer.queue.RenderQueue.renderQueue(RenderQueue.java:305)
	at com.jme3.renderer.RenderManager.renderViewPortQueues(RenderManager.java:870)
	at com.jme3.renderer.RenderManager.flushQueue(RenderManager.java:781)
	at com.jme3.renderer.RenderManager.renderViewPort(RenderManager.java:1097)
	at com.jme3.renderer.RenderManager.render(RenderManager.java:1145)
	at com.jme3.app.SimpleApplication.update(SimpleApplication.java:253)
	at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(LwjglAbstractDisplay.java:151)
	at com.jme3.system.lwjgl.LwjglDisplay.runLoop(LwjglDisplay.java:193)
	at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:232)
	at java.lang.Thread.run(Unknown Source)

It is not your Code and the sdk also suffers from it.

You can try to debug a bit by exporting to xml.
The Issue does it happen when your node is never ever seeing the update method in Hardware skinning

1 Like

Can you explain more? Are you saying this is a bug in JMonkeyEngine? If so, do you know what the cause is? If I exported to XML, I wouldn’t know what to look for, since I don’t know what this is complaining about.

Could you rephrase this? I don’t understand what you’re saying.

What version of JME are you using?

1 Like


Can you try beta2? Some cloning fixes were made. Actually I think there might even be some cloning fixes on head. I plan to do a beta3 soon also in case beta2 doesn’t fix it.


Yep! Beta2 fixed it. Thanks!