[SOLVED] jME Applet, again


i'm sorry to start this thread. I know there are several others about this topic but they were no help.

I want to embed an applet into a browser and the applet code is the one from the wiki page about applets. It runs fine in Eclipse so i guess so far is nothing wrong.

But if i export into a .jar file and try to embed it in html i get nothing, the appletloader seems to work but then it stops with a white (sometimes gray) window inside the browserpage.

This is the applet-code, it's copied from another thread and modified it a little (my Applet is in se1.jar in package se1.applet)

<applet code="org.lwjgl.util.applet.AppletLoader"  archive="lwjgl_util_applet.jar, lzma.jar"  codebase="."  width="640" height="480">
<param name="al_jars" value="lwjgl_applet.jar.pack.lzma, lwjgl.jar.pack.lzma, jinput.jar.pack.lzma, lwjgl_util.jar.pack.lzma, res.jar.lzma, se1.jar, jorbis-0.0.17.jar,jme.jar, jmetest.jar, jmetest-data-images.jar">
<param name="al_logo" value="appletlogo.png">
<param name="al_progressbar" value="appletprogress.gif">
<param name="al_title" value="AppletTestBoxColor">
<param name="al_main" value="se1.applet.AppletTestBoxColor">
<param name="al_windows" value="windows_natives.jar.lzma">
<param name="al_linux" value="linux_natives.jar.lzma">
<param name="al_mac" value="macosx_natives.jar.lzma">

Has anyone an idea what went wrong? I know it's hard to say anything because of the lack of info, but i would be glad if someone could help me.


EDIT: oh and i use jme2 - could it be better to switch back to jme1?

Make sure you sign your applet jars.

Yup, i signed them

check if there is a error message in the java console or in the java logfiles

currently it sais:

Exception in thread "AppletLoader.loaderThread" java.lang.UnsatisfiedLinkError: Native Library /tmp/appletloadertest/natives/liblwjgl.so already loaded in another classloader

Yeah i encountered that problem too, reloading of an applet seems to be a problem.

You need to close all instances of the browser and try again.

Only closing a tab in Firefox is not enough, you need to close all Firefox instances (even the small download window)

mmh maybe there is another problem

i can

heh you found the applet generator, it was just made to learn Google GWT a bit, its not very useful at the moment.

the applet works in firefox 3 and IE 7, but somehow they won't start in IE 6 or Firefox 2.

I don't know why and have no time to look into it :/.

hehe yes found it but i am using firefox 3 and it doesnt work.maybe a new firefox problem ?


i couldnt solve the problem with jme2 so i tried jme1 and it worked right from the start with lwjgl 1.4.1. I guess i'll use jme1 for now and i hope there won't be anything that i miss.

Thanks for the help anyway! Oh, and feel free to hijack this thread. :slight_smile:

Hi again,

is it possible to call a JMEApplet function from outside of the applet? Maybe by JavaScript or something?

EDIT: I could solve this by myself via JavaScript and i hope this was my last question for a while