[SOLVED] jMonkeyPlatform hangs on startup

Hi all,

I’ve just downloaded the jMonkeyEngine/Platform (from the main downloads page) for the first time and tried running it on my 2011 MacBook Pro running OSx Yosemite 10.10.4. I simply unzipped the download and dragged the application to the Applications folder. The first time I ran it, the loading screen ran properly, I was asked to set the folder and the loading progressed. Then the IDE opened, and loaded all the windows including the content in the Info Screen and a small popup telling me there were 35 updates that needed to be installed.

But as that was happening, spinning beachball of death.

I’ve tried several times including:

  • restarting the system,
  • clearing preferences and settings (also cleared NetBeans settings just in case),
  • tried changing heavyweight canvas settings as described in the sdk:troubleshooting guide
  • tried changing the look and feel to nimbus as described in the sdk:troubleshooting guide (the gui did have the nimbus laf but still hung the same way),
  • deleted the application, cleared settings and re-installed it

Nothing has worked.

My messages.log: http://pastebin.com/CPyBUSdZ

Thanks if any of you have any extra suggestions.

And the problem seems to have been solved!

I was trying to turn off background programs one at a time to see if they were somehow interfering with the program, and after turning off a piece of productivity tracking software called Rescue Time, suddenly it could load. I started everything else back up, still fine, and when I tried starting Rescue Time up again, the problem returned. I could turn RescueTime on again while the jMonkeyPlatform was running and everything seemed to be fine.

So that was weird. But at least solved. Anyone else using jMonkeyPlatform and Rescue Time with or without problems? Any ideas what could have caused the conflict and how it could be fixed? A minor inconvenience but I’d love not to have it.