[Solved - kind of]Problems runing HelloWorld example

Hello,

I'm starting to learn Jme and i'm having problems to run the HelloWorld example from the tutorial.



I did a search on the forum and i see my problem is very common.



here is my problem:



Nov 12, 2007 3:11:46 PM com.jme.app.BaseGame start

INFO: Application started.

Nov 12, 2007 3:11:46 PM com.jme.system.PropertiesIO <init>

INFO: PropertiesIO created

Nov 12, 2007 3:11:46 PM com.jme.system.PropertiesIO load

WARNING: Could not load properties. Creating a new one.

Nov 12, 2007 3:11:46 PM class HelloWorld start()

SEVERE: Exception in game loop

java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path

at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1682)

at java.lang.Runtime.loadLibrary0(Runtime.java:823)

at java.lang.System.loadLibrary(System.java:1030)

at org.lwjgl.Sys$1.run(Sys.java:75)

at java.security.AccessController.doPrivileged(Native Method)

at org.lwjgl.Sys.doLoadLibrary(Sys.java:68)

at org.lwjgl.Sys.loadLibrary(Sys.java:84)

at org.lwjgl.Sys.<clinit>(Sys.java:101)

at org.lwjgl.opengl.Display.<clinit>(Display.java:111)

at com.jme.system.lwjgl.LWJGLPropertiesDialog.<init>(Unknown Source)

at com.jme.app.AbstractGame.getAttributes(Unknown Source)

at com.jme.app.BaseGame.start(Unknown Source)

at HelloWorld.main(HelloWorld.java:16)

Nov 12, 2007 3:11:46 PM com.jme.app.BaseSimpleGame cleanup

INFO: Cleaning up resources.

Nov 12, 2007 3:11:46 PM com.jme.system.lwjgl.LWJGLDisplaySystem <init>

INFO: LWJGL Display System created.

Nov 12, 2007 3:11:46 PM com.jme.app.BaseGame start

INFO: Application ending.



I downloaded the nighty build,

added the Jme Jars to my project,

added the lwjgl.jar to my project

added the -Djava.library.path="/home/nando/Jme/lib/" (which is the location os my .so files)



and I still got the problem, I using eclipse and my OS in Linux (ubuntu)



hope someone can help me






Perhaps you have a problem with the versions… Do you have a 64 bit java virtual machine? (you can figure it out with java -version). Also, you can check the type of your lwjgl library by running file liblwjgl.so in the terminal. Finally, check that the path is completely valid, (it is case sensitive), do something like ls -l /home/nando/Jme/lib/*



Good luck.

i had this problem:



find all the files you downloaded to do with lwjgl, go to the folder called native.

move the file called lwjgl.dll into your classpath, that should do the trick.

The problem with that approach is that it is not very easy to update jME then… And also you might later forget and update locally and then be puzzled because it throws a UnsupportedOperationException or something like that because it is using an outdated version hidden somewhere in your path instead of the new version.

I "solved" the problem by brute force,  }:-@

moved the .so files to the lib directory of java



I now it is not the best solution, but I'm just learning the engine.

so for that is ok



thanks for the help

Just keep it in mind that you did that, and you will have to do it every time you update, and if at some point it stops working, that should be the first thing to check.



Other than that… glad it is working.  :slight_smile: