[SOLVED] Lemur init in Ubuntu

Hello I am trying to run my project under Ubuntu (it works under Windows well), it compiles but when I try to run it from IDE I am getting this:

Aug 13, 2015 5:03:33 PM com.jme3.app.Application handleError
SEVERE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]
java.lang.NoClassDefFoundError: com/google/common/io/Resources
	at com.simsilica.lemur.GuiGlobals.logBuildInfo(GuiGlobals.java:165)
	at com.simsilica.lemur.GuiGlobals.setInstance(GuiGlobals.java:119)
	at com.simsilica.lemur.GuiGlobals.initialize(GuiGlobals.java:113)
	at devpanic.Main.simpleInitApp(Main.java:90)

And that line is


Where to dig to fix it, thanks!

You don’t have guava as a dependency, I guess… not sure how it worked on windows unless you’ve done something screwy like add guava to your global classpath or something.

Hmm I don’t remember if I downloaded it separately so having it working means it came with IDEA or some android sdk and so was put somewhere it is still accessible from. I will try to investigate further tomorrow, thanks!

Update: indeed guava was there in libs but wasn’t added in project libs somehow. Thanks Paul!