[SOLVED]LWJGL silent fail

This is either something very noobish or something incredibly complex. I’m running a jme app in eclipse and it works fine. When I export it to jars, it doesn’t work anymore. But exported app worked untill some days ago, and I don’t get whats wrong.

After clicking Ok from the property selection screen (resolution, depth etc), the display is created for few milliseconds, than it closes giving no errors…

This is all the log:


[adriano@PowersourceII Scrivania]$ java -jar testJME/testJME.jar

9-nov-2011 23.35.00 com.jme3.system.JmeSystem initialize

INFO: Running on jMonkeyEngine 3.0.0 Beta

9-nov-2011 23.35.00 com.jme3.system.Natives getExtractionDir

AVVERTENZA: Working directory is not writable. Using home directory instead.

9-nov-2011 23.35.00 com.jme3.system.Natives extractNativeLibs

INFO: Extraction Directory: /home/adriano/.jme3/natives_ae154f06

9-nov-2011 23.35.00 com.jme3.system.lwjgl.LwjglAbstractDisplay run

INFO: Using LWJGL 2.7.1

9-nov-2011 23.35.00 com.jme3.system.lwjgl.LwjglDisplay createContext

INFO: Selected display mode: 640 x 480 x 0 @0Hz

[adriano@PowersourceII Scrivania]$


You can test the same app from this download link: Download JIVES from SourceForge.net (Sorry for the big size)

does it start on your machine? This might be related to some video driver update…

You somehow managed to mix the wrong natives.jar and ljwgl.jar

This was a faulty CVS update… me noob!

i have the same problem could you tell me please how did you resolve it