[SOLVED] Material Editor

Hey everybody,

I’m having an issue with the material editor, if that’s what it’s called.

When I open a .j3m file I’m getting the screen with all the options to tweak the material.

Though I think there should be checkboxes under the options tab, which I seem to be missing.

Here is a screenshot of what I mean. There are these gray boxes after the options, but I can’t interact with them.

My assumption for there to be checkboxes came after watching this video:


I’m using Ubuntu 11.10 on a Mac mini.

I’ve tried using different java SDKs and I’ve also tried to use different gtk+ theme’s. But that didn’t change a thing.

Thanks in advance :smiley:

Greetz Ertyui

Change the look and feel using the --laf command line option.

1 Like

Thank You!! that worked perfectly, to clearify for other users (on ubuntu) with this problem.

Start jmonkeyplaftorm as follows:

./jmonkeyplatform --laf (complete class path of the look and feel)

for example:


./jmonkeyplatform --laf javax.swing.plaf.metal.MetalLookAndFeel


./jmonkeyplatform --laf com.sun.java.swing.plaf.motif.MotifLookAndFeel

Nimbus and GTK+ didn’t seem to work.

These are standard in java 1.6

There are also custom lookandfeel project which you can try with the following command:

./jmonkeyplatform --laf (complete class path of the look and feel) -cp:p (path to the jar file, of the look and feel)

For example:

./jmonkeyplatform --laf com.birosoft.liquid.LiquidLookAndFeel -cp:p /home/Ertyui/Local_Apps/Java_LAFs/liquidlnf.jar

Hope it helps :slight_smile:

Thanks again :smiley:

Greetz Ertyui

Edit: P.s. Why does this forum makes a double - into one long -?

It messes up the examples.

1 Like

Thanks, I’ll try that :D. the default looks’n feel on ubuntu is ugly :).

Yeah it is. I like the Metal one :slight_smile: