[SOLVED] NiftyGUI classes have errors in my engine!

Hello people,

I’ve been reading on the loading screen tutorial on GitHub. I’ve stumbled…
I tried the terrain/nifty tutorial on my engine and the classes aren’t installed on my engine. What do I do?

Please show us more information so that we can figure out what’s going wrong.

Maybe some screenshots, maybe the Exceptions, maybe more description.

Well, there isn’t really anything to screen shot. But I downloaded the NiftyTutorial zip file off of jmonkey tutorials website. But as I opened the project into my jmonkey engine, I’m getting errors on all of the applications. I think I read something about “resolving the issue by finding a JAR file” but I have no idea where to look.

Some of them come out in errors as AssetNotFoundException. Its saying it can’t find the imported class.

It’s saying the importations do not exist

Using Nifty-GUI need follow jars:

  • jME3-niftygui
  • nifty.jar
  • nifty-style-black.jar
  • nifty-default-controls.jar

Using Terrain need:

  • jME3-terrain.jar

where would I get these files

Do you use JME3 SDK or not?

uh yes haha. just a little thick over here

  1. Right click your project.
  2. Select “Properties” at the bottom of the popup menu.
  3. Select “Libraries” in left pane of the “Project properties” dialog.
  4. Click “Add libraries” button at right pane.
  5. Choose every jars you need.
1 Like

Thanks! the errors are gone and the importations now exist