[SOLVED] No loader registered for type "mesh.xml"


#1

While following this tutorial: https://jmonkeyengine.github.io/wiki/jme3/beginner/hello_asset.html

I get the following exception: com.jme3.asset.AssetLoadException: No loader registered for type “mesh.xml”

On the line Spatial ninja = assetManager.loadModel(“Models/Ninja/Ninja.mesh.xml”);


#2

you are missing the “jme3-plugins” dependencie look here to see how to add it:
https://jmonkeyengine.github.io/wiki/jme3/maven.html


#3

Thanks, fixed the problem with the above solution.


#4

Hello - Is there a way to know - i.e. via some kind of list or other mapping - which JARs contain which resources? Thanks


#5

Does that have anything to do with this thread? What are you actually trying to do?

The question is broad enough as is that my tendency would be to point you to google. So maybe you mean something more specific?


#6

Sure. Here’s the context. I am evaluating jmonkeyengine. I’m doing my work in IntelliJ because that’s the tool I’m familiar with. In going through the tutorial starting at #1. I get to #3 - Hello Assets. I copy/paste the code into IntelliJ. I run it. I get an exception (as pdid described.) I google it. I get here - this page. I add jme3-plugins my my pom. Looking at the page referened by the link, it says “the following artifacts are currently available…” of which jme3-plugins is listed. However, it’s not clear which JAR is required to provide any different resource. I suppose I could add all JARs but - I wondered if there might be some resource that helped narrow that down.


#7

https://wiki.jmonkeyengine.org/jme3/maven.html