[SOLVED] SDK installer GUI doesn't show up on bspwm (Arch Linux)

I’m using the window manager bspwm (on Arch Linux), and the jME SDK’s installer is not working right:

The GUI is completely white, but is functioning, since I can click near the bottom-left corner to trigger the cancel warning:

I tried changing size, turn on/off fullscreen and change the window from workspaces, but it just won’t work.

Is there any way to install the SDK through CLI or with a -silent option? Or, in case not, can someone post screenshots of a working GUI so I can see where should I click?


The best way is to use the zip file which is platform independent (you only have to execute the correct file in bin/).
What you do miss is the bundled jdk and blender, but both are no show stoppers.

You can also try --help or something, maybe the installer has a cli. But I’m not sure.

Can you maybe report this Issue on the Github Issues?
Do other Java AWT/Swing applications behave like that?
Because the next question is if the SDK will run then.

Did you maybe set a custom look and feel?

Edit: I just checked - Tiling Window Managers will always be problematic for UI-heavy programs.

Thanks for the answer. Through the --help command I found out there is a --silent command. However, it simply extracts the contents of the .sh file, so no big help…

I did however discover an arch wiki page dedicated for Java problems with bspwm. I’ll see if it helps me, otherwise I’ll just download the .zip file as you said.

ATM I don’t have any apps installed that use Swing, but I have a couple of Java/jME projects that rely on it. I’ll try compilling them and see how the look like.

EDIT: By appending export _JAVA_AWT_WM_NONREPARENTING=1 to /etc/profile.d/jre.sh, the problem was solved (as stated on the link above). But nevertheless, thank you!