[SOLVED] SDK version 3.5-sdk2 won't run

I’ve just recently tried upgrading to the newest version of the SDK, but it is not launching on my device. The loading splash screen comes up and makes it about 80% of the way and then closes on the “starting modules” step and doesn’t give any error or anything.

I tried installing the windows64 version and also downloaded and tried running it from the zip version, but I’m having the same issue with both.

The device I’m having trouble with is using windows 10, Intel(R) Core™ i7-7700K CPU, 16gb ram, and NVIDIA GeFore GTX 1080 GPU

Thanks :slightly_smiling_face:

1 Like

Is it a clean install, or installed on top of an old version?

1 Like

I still had an old version (sdk 3.3.0-stable) on my device, but in a different location. I will try removing that and installing again.

I uninstalled the old sdk and re-installed 3.5-sdk2 so it is the only one in the ProgramFiles directory now, but it still won’t launch the new version unfortunately.

Edit: I also tried the past few SDK versions I skipped on this device (sdk 3.5 and sdk 3.4) and both have this same issue. So I had to revert back to SDK 3.3.0 stable which appears to be the latest version I can run.

did you check on what java jdk version, new installed sdk is using?! check on sdk etc folder and in config set the jdk home.

netbeans.exe --jdkhome "C:\Program Files\jdkVersion" can set it too.
1 Like

It appears I’m only using openJDK 11.

So I think I need to upgrade to at least JDK 14 to use the newer SDKs since they use a newer version of netbeans, is that correct?

Update to jdk 17, for using several netbeans in different versions you can set each version jdk by various options. I’m sure i had this problem back in time that what jdk netbeans use itself to run. by the way having several jdk is always good but be aware which of them is your java_home. can make problems without even any sign to identify better using zip than installer. I’m not sure if this solve your problem, but just have a test

1 Like

You have to do this:

Note for upgrading from previous SDK versions

There is no upgrade path per se, but if you have had any older SDK version on your computer. This new version might fail to start. To fix this you need to delete the following folder (old SDK settings):
C:\Users\user\AppData\Roaming\jmonkeyplatform (Windows)
/home/user/.jmonkeyplatform (Linux)


JDK version doesn’t matter. The SDK comes with JDK 11 and uses that to run itself. You can have multiple JDK versions installed on your computer and add them as Java platforms in the SDK in order to use them (in addition to the bundled one).

The latest SDK sports NB 16. Which… I believe might even let you go up to JDK 20 (unreleased, preview).

1 Like

I added this to the release notes. Maybe we need a FAQ or troubleshooting document, somewhere.


This solved the issue and I’m able to run the latest SDK now, thanks!.