[Solved] Spatial disappearing in some directions (sim-eth-es)


I’m encountering an issue that seems odd. And I think I’ve encountered it before, but I couldn’t find it on the forums. I’ve added a quad in the x-y plane in sim-eth-es and positioned it at (0,0,0). Its 25 wide and high. If I choose to move (the player and camera) in the -y direction, the spatial disappears when it should still be visible (when the center of the spatial is not in view any more). If I move in the +y direction the spatial stays visible as it should even though the center of it is out view.

This is my spatial creation:

private Spatial createArena(Entity e) {
    Quad quad = new Quad(arenaSize, arenaSize);
    //<-- Move into the material?
    float halfSize = arenaSize * 0.5f;
    quad.setBuffer(VertexBuffer.Type.Position, 3, new float[]{-halfSize, -halfSize, 0,
        halfSize, -halfSize, 0,
        halfSize, halfSize, 0,
        -halfSize, halfSize, 0
    Geometry geom = new Geometry("Arena", quad);

    Material mat = new Material(assets, "Common/MatDefs/Misc/ShowNormals.j3md");

    return geom;

I didn’t pick ShowNormals by intent, just to get something showing on the spatial.

Looks like bounds aren’t updated

1 Like

Thanks. Worked.