[SOLVED] Start button

Hi, guys!

I have a Logitech Gamepad F710 controller and the start button is not recognized – either on XInput or DirectInput modes. It seems like it is not mapped on JME or something. Is there any way to make that button work? What should I do?

How are you determining that it’s not mapped?

Did you run the TestJoystick application to see what’s being logged?

I did fire up TestJoystick and it doesnt even recognize it as a button (xbone s an logitech chillstream pads). It seems like a lower level issue.

Then the question is lwjgl2 or 3?

Yes, and I confirm what @grizeldi said: it is not recognized as a button. Nothing is logged.

I also ran this test from LWJGL on Github. There is a line that says unknown that responds to the start button.

Seems that LWJGL 3 mentions the start button at least. The test you tried is for the LWJGL 2.

Yes, that’s what jME 3.2 uses by default, right?

Yep, my guesstimate is that more than half of JME users use the default. But it is fairly easy, and supported (?) to change it to use LWJGL 3. We have made the change long time ago.

LWJGL 2 has some fixes queued. But I doubt that they (spasi) ever make a new LWJGL 2 release. 3 is the future.

1 Like

The problem for me with lwjgl 3 is that AWT breaks it. I’d have to redo a bunch of stuff to move.

I’ve changed to LWJGL 3 and now everything works. Thank you everyone!

1 Like

What does it do exactly? And does Lemur support lwjgl 3?

Fails to start I guess. I don’t remember the specifics.

Lemur doesn’t care.

So AWT don’t run when you use LWJGL 3? Then that’s fine :+1:


Makes it sound like the opposite, so when you have awt (when you instance a Frame maybe?) then lwjgl 3 is broken?

You’d have to search the forum for the exact issue… but yes, you can’t use the settings dialog… you can’t pop open any other AWT-based splash screen or login dialog… or anything. If you do then the app will fail to load.

I’d have to totally rewrite the Mythruna loader to use lwjgl3 because of their “bug that won’t be fixed”… or switch to jogl and deal with those issues.

I’ll probably reimplement the settings dialog in jme then… the only case where is necessary the awt loader is when the game fails to start and might be relegated to “compatibility mode”

Not as bad as it sounds. Only affects Macs. But yes, even without AWT stuff you need some extra parameters to run it on Mac.

1 Like

With Apple deprecating OpenGL, this issue might not be nearly as significant to quite a few developers in the near future. :wink:

1 Like