[Solved] SUMA of Export / Blender / invert surface / aplha / shadows errors > Help PLS

Hello. It’s me. Again :frowning: I try, try and try but…

  1. I created my own 3D model (with animation) in Blender 2.62. I did everything same like in the video http://www.youtube.com/watch?v=qXYEU0F30Ak >> After export through OGRE wish same parametres like in the video my model have have invert surfaces (similar like CullHint) and without material > “No material file found for cube.mesh.xml” when i open it. Look at image number “3”.
  2. My water do some error when cam is on some angle > Image number “1”.
  3. My objects in scene are Boxes createt like (1,1,0) > 2D box/square + texture with alpha + blend alpha modofier + geom.setQueueBucket(Bucket.Transparent); => 2D object. Look at image “2” > under some angle alpha hide else object with same parametres.

    *4) I will wanna create shadows from edge by this 2D objects. I don’t try yet but i asked when i am writing this topic. Shadows will be throw by square or by edge of aplha image? If “by square” > i would do model for every image model with shape of edge for I achieved an wanted shadow?


    If you help me i will be glad again :slight_smile: i hope that i will do it fast and you will see my game like your reward.

    PS: Before i wrote this topic i looked at other topics but…“not found similar topic” Sry if i annoying you.

For #1, The material needs to have the same name as the model, also check the normal vectors in blender to make sure they point outward.

For #3, you should be using billboard control/node, not boxes

For #4, see the example TestTransparentShadow

1 Like

for #2 play with the WaterProcessor’s setReflectionClippingOffset (float val), default is -5 try to get it higher.

1 Like

i will. THX

with first problem >> i instaled plugin from JME, export again and rename material file. If i open “file.scene” > object seems be fine BUT “file.mesh.xml” have still inverted normal vectors(when i see at him after convert to j3o OR loaded like .mesh.xml in game). I have checked vectors in the Blender and everything seems be OK. *If i export model like “file.OBJ” and ope it in jME > model is OK but this don’t complain animations.

SUMA: .scene > OK; .mesh.xml > invert surface; .obj > OK

info: water error is mirror of terrain under water there go more deeper.

problem with 2D object > alpha error =>>> I used Quad + billboardControler. Error still during. Error is not make by rotate of image but by angle of camera throw two object with .setBlendMode(BlendMode.Alpha);

I have problem with my cam. My scene complain rootNode and sceneNode. My game stop rendering when cam don’t complain any object from rootNode! But sceneNode is attached to rootNode!

Hello… I’m bringing new INFO about my issues.


  1. i still work on them > i will try create new model :frowning: every else models exported throw ogre seems be fine.
  2. [SOLVED] I used WaterFilter. Look more beautiful and without errors => wish one linked with my problem number “3” (water didn’t rendered throw alpha material) this is solved look at >> 3)
  3. [SOLVED] My materials.j3m didn’t set “AlphaTestFalloff 0.0”. This cause missing objects + anti-rendering WaterFilter.

    *4) work it :slight_smile: > thx to TestPostWater

    new) [SOLVED] I don’t know why but when my can didn’t see something from rootNode > game have stoped rendering(but in rootNode was sceneNode with other spatials). SOLUTION: rootNode.setCullHint(Spatial.CullHint.Never);

    THX everybody and i hope thet this topic will help somebody else with same problems.