[SOLVED] Windows 7, projects and correct version of lwjgl.dll

Ok… I hope I state this correctly.



pspeed gave me a hint as to why I am having an issue with Beta. However, I can’t seem to figure out how to ensure the correct version of lwjgl.dll is being used by projects. (Windows 7). This dll seems to be everywhere :slight_smile: It is under my user directory, and every project folder I have created. The modified date on these varies from instance to instance of the dll. None have any file details about what version the dll is… etc, etc, etc.



How do I ensure that the correct version is being used? And where it is begin used from? I can’t seem to track this down…



Yes, I am an idiot. But a nice idiot.



Thanks in advance to any who can help!

there might be ones in (user home)/.jme3/ (apart from the project root)

@normen said:
there might be ones in (user home)/.jme3/ (apart from the project root)


Do I need to remove these? Or?

Each application will always regenerate these if they are not there (and should if they are outdated but that seems to fail lately @Momoko_Fan).

Gonna remove all and see what happens :slight_smile: Thanks!

Well… I am getting closer. This solved the issue with any window created by lwjgl crashing.



Now, I need to reinstall beta and see if I can resolve the other issues I’ve been having (which I believe are due to updating to nightly to see if it would fix this issue. hahaha)



BIG thanks @pspeed and @normen for the help!

Always remove the one in your user home directory.



See, there was this bug that caused JME to expand it there… which a DLL there will often take precedence over any other version of this DLL. But then when the bug was fixed, that DLL doesn’t get updated anymore and so you’ll get a new one in your project directory like you are supposed to… but the game will still be using that old crufty one from your user directory.



And generally, deleting the JME-related DLLs is always safe because the application will just reextract them when needed.



Glad it worked for you.