Some Bugs

Hey Guys,
i think, that i found some buggs in the SDK Software.

  1. If you go into Power Save Mode and repower the Scene Editor will be Black.

  2. I can’t create an Quad with an Integer or an Fload.

I using the SDK Version 3.3.0.

2 Likes

The SDK only provides basic functions. To create complex models, you should use modeling tools, or create a 111 grid, and then use zoom.

Thanks for the report. We’ll take a looksie.

1 Like

Thank’s :slight_smile:

That was fast, @Darkchaos already fixed it to the main. So it’ll be working on the next SDK release then :slight_smile:

1 Like

@tonihele
When will the next sdk release be?

Maybe @Darkchaos can shed some light on that. There has been some progress and the platform is now updated to Netbeans 12 LTS. 3.3 milestone is not yet hit, dunno if there would be some beta/alphas before that.

I’d like to have the milestone reached before releasing, especially because we have a lot of breaking changes and thus would like to see feedback:

  1. Gradle (We want to have a fully featured template that also works with android studio and should have an exhaustive check list for all the features)
  2. The new animation system (we’ve had a lot of crashes due to that, and still have #252)
  3. Core profile on Mac OS X for at least OpenGL past 2.1
  4. The new module system/update center. I’ve started working on it, it is fully hosted on github. We should have that, so we can prepare hotfixes (which might make us get away without fully fixing 1-3), but especially also have a nightly going on in 3.4 releases, so anyone can easily help us test and fix from there on.
  5. The new module system also allows us to cut down size, things like the nifty editor and ogre could be optional
  6. Speaking of Ogre, we should check how that works, since it probably still uses the old animation system and is not blender 2.8 compatible, but still it is the go-to way for a lot of people on legacy ways
6 Likes

Looking forward to the next sdk :+1:

2 Likes

Actually that being said, if someone wants to help with these issues and be it only testing, you are more than welcome to do so :slight_smile:
The hardest part is getting the SDK to build locally

2 Likes

I have been using the SDK, and I have always wanted to develop plugins for the SDK, but I am not yet familiar with the plugin development process of netbean. :pensive:

Do you have any suggestions to help build the SDK locally?
I have also tried but are struggling the last time I tried.

I just commited something which should get us rid of the jogl problem, all that is left is:

  1. ./build_engine.sh
  2. ./fix_engine.sh (not sure if it is still needed(?))
  3. ./gradlew buildSdk
  4. ./gradlew run (or use the downloaded netbeans in the netbeans folder to open the SDK Project and run/debug)

If there are any issues, just tell me. If it’s something with jogl, your engine folder needs to be reset to v3.3 of jme (not master).
To future readers: Always consult Travis or Actions

Edit: Forgot an important thing! You now need at least JDK 9 I think (def not 8), and on Debian/Ubuntu/Derivatives you even need AdoptOpenJDK as your JAVA_HOME, because otherwise the SDK will just crash (This is lwjgl2’s and libc’s/openJDKs fault)

1 Like

Hi @Darkchaos,

I tried now again to build the SDK locally. I got a little bit further but now I get this HARD error. Any idea how to solve it?


> Task :buildSdk
Trying to override old definition of task updatenbdeps
Trying to override old definition of task updatesdkdeps
Trying to override old definition of task loadwikiimages
Trying to override old definition of task fixwikilinks
[ant:nb-javac] javac: invalid target release: 10
[ant:nb-javac] Usage: javac <options> <source files>
[ant:nb-javac] use --help for a list of possible options

> Task :buildSdk FAILED

FAILURE: Build failed with an exception.

* Where:
Script 'C:\Backups\jME3.4-SDK\sdk\build.gradle' line: 646

* What went wrong:
Execution failed for task ':buildSdk'.
> The following error occurred while executing this line:
  C:\Backups\jME3.4-SDK\sdk\netbeans\harness\suite.xml:163: The following error occurred while executing this line:
  C:\Backups\jME3.4-SDK\sdk\netbeans\harness\common.xml:204: Compile failed; see the compiler error output for details.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 11s
7 actionable tasks: 2 executed, 5 up-to-date
1 Like

What is your jdk Version? It’s does not Support java 10, so its either jdk9 or they removed java 10 Support on new jdks

I have installed and configured jdk9.

Yeah, this is the problem, sorry for the outdated information above, seems like we bumped the JDK requirement to 10 (but I would only recommend installing jdk 11, because that’s LTS).

I also triggered a new release, it just looks like I forgot to push the tag, I’m sorry, will do now.
Everyone using it keep in mind: There are still bugs, some might be known, others might be not, please compare to the issues and be careful when using it on production projects (i.e. have backups).
We also have an auto update nightlies system again, but due to a few issues, it is not yet enabled.

Edit: Looks like the build broke again, sigh…

@Darkchaos
Please let me know when I can pull and try to make a build again.

Well you can already, but you’d need Java 10+,
But https://github.com/jMonkeyEngine/sdk/releases/tag/v3.3.2-stable-sdkpreview1 is now finally online, so you should be able to use that.

2 Likes