Some Extra Plugins can't run anymore

I’ve just make a “bad” decision that download the SDK-Alpha4 and then delete the old SDK-Alpha3 (with current updated) and install …

Then what happen is some plugins (Groovy , Jython , many more … which I can install in last version ) can’t install and raise these errors :

Some plugins require plugin Lucene Integration to be installed.
The plugin Lucene Integration is requested in version >= 2.1 (release version 1) but only 3.1 (of release version different from 1) was found.
The following plugin is affected: Python

Some plugins require plugin Editor Library to be installed.
The plugin Editor Library is requested in version >= 2.1 (release version 2) but only (of release version different from 2) was found.
The following plugin is affected: Python

So , the current Netbean Platform of SDK-alpha4 is different from Netbean 6.9.1 (which is in SDK-alpha3) ... How can I work around this problem , plz..

You simply deleted the settings folder, its used for both versions. Just reinstall alpha-4

@normen : I reinstall SDKalpha4 but it’s no effect . The error still remain … Can you use the Groovy plugin in the new SDK sir …?

Enable the NetBeans plugin center. If plugins from there have not been updated yet you’ll have to wait for NetBeans 7.0 to come out so the plugins get updated.

:expressionless: It likes something collapsed in me …

Those uncompatible plugins force me make a hard choice to return to SDKalpha3 for a while and develop my others plugins in SDKalpha3; cause some of my system lied too much in Groovy, and the Perspective plugin (which doesn’t work too)

I was having the same problem with groovy, but I enabled the jMonkeyEngine SDK Nightly Update Center and after installing the rest of updates it worked well. Only be sure if enabling Nightly is really what you want.