Something weird with RenderToTexture

Hi all,

I was just working on glow when I noticed a hickup with render to texture

These tests were taken at 800x600, at 640x480, just a black bg is rendered to the renderToTexture Texture.

The RenderToTexture seems to init fine:

Jun 24, 2004 12:15:51 PM com.jme.renderer.lwjgl.LWJGLTextureRenderer <init>
INFO: Render to Texture Pbuffer supported!

is it a lwjgl issue?


Dunno what might be wrong on your end. Those tests run fine here. Given the repeated fps counter in the camera man monitor, it looks like it may be having problems copying over the rendered texture or drawing on the pbuffer or something like that. I do get an occasional free up memory dialog when I quit, but otherwise it runs normally. You are using a modified jme so hard to say… have you tried checking your card settings, etc? full screen vs. windowed?

PS: 640x480 will have a small band on one side in the render to texture test because it is asking for a 512x512 texture. Camera man compensates for 640x480 though and shouldn’t show any artifacts.

DP, for one thing, TestCameraMan does not display the FPS and vertex count in the texture display, so your test is not even the same.

Secondly, I don’t know what you did to your local copy, but Renanse tells me you have been modifying base components. If this is true, how can we support you? You’re no longer working on the same code.

CameraMan works fine on the 3 seperate computers I have, including webstart.

"mojomonk" wrote:
Renanse tells me you have been modifying base components. If this is true, how can we support you? You're no longer working on the same code.

Sounds like I'm tattling or something. :P DP, you mentioned to me that you decided to do things differently in your local source of jME due to some changes you wanted for your game. Could these changes have affected the rendering (not specifically render to texture) process?

right, the only thing that is different is the particle system.

And mojo, yes, I know its not supposed to display the FPS and vertex counter in the TextureQuad, but it does.

Let me pull a fresh copy of jME and il test it.

Try web start as well.

tried that, no luck