Sourceforge anonymous keeps timing out on me. Is there any place else I can get the source? Is there any reason it's not in the normal jME jmex repository?

Is there any reason it's not in the normal jME jmex repository?

Basically, because it is not part of jME. This is in the sense that it's not maintained by the jME devs. By keeping it seperate like that it gave Per and (at the time)DarkProphet the freedom to do whatever they wished to the library without having to deal with going through us.
Slowdive said:

Is there any place else I can get the source?

No, please complain at sf  :|
Btw: works fine over here - maybe you should simply get a login?

It actually looks like they've disabled anonymous reads. I really don't want to pay 6 bucks a month for a login that I might only use once.

Hmm, based on what?  I think they'd have a big issue on their hands if they disabled it.  But companies do silly thingsā€¦

Well I received various authentication errors asking for a login, or saying that anonymous is not allowed. I've tried other modules as well, following their precise instructions to the letter. I guess I could be doing something wrong. I don't know. Has anyone here been able to anonymously access Sourceforge lately?

Um, sourceforge login does not cost anything (at least the standard stuff).

You are correct. I kept going to the new account page and all it did was talk about paid subscriptions. Created account, tested it by logging into the website, no problems. Try to checkout the module and it aborts saying no such user. Nice. It lets me authenticate, but then not do anything because my username doesn't exist. What a nightmare.

That's normal with sourceforge. They use cron jobs to sync the system user accounts with the database  . Wait a while - at least after a day it should work.

Ok. I would've figured that if it didn't just give me a message saying my account would be immediately available.

Well I still get the no such user error message. Can anyone see a problem with my CVSROOT?


Module and pathname on the server is set to:


Any thoughts where I'm screwing up?

i think it should be more like:


(2401 being the port) but not sure as i use NetBeans and that has a fancy dialog box for this

Hmm, tried that but got a no such host is known error. Thanks for the suggestion anyway. I'd really love to use the physics lib, but this is getting nuts.  :expressionless:

well, then i can only point You at the sf cvs doc's  (incase You haven't read it already):

Yes, I've read that page and others like it and tried everything. On one of my machines I get all the login error messages. The other just sits there indefinitely trying to log in. I've turned off all firewalls, etc. Nothing seems to work. I went so far as to using the web interface and copying and pasting all the code and creating all the files on my machine, but I get problems with missing methods in odejava (using the jar). I guess I have to copy and past all the ode stuff too. Unless someone would be willing to email or throw a tar or zip of the complete source up somewhere that I can get it?

The odd thing is, I have zero problems getting jme out of cvs on So go figure.

Slowdive said:


Hmm, what client accepts this?
The cvs from has this syntax (as do all the clients I know):

Before checking out you would do a cvs login...

What client do you use? Or is the problem solved in the meantime?