Specular Not Showing

I imported a model and created a .j3m material. However, when I set a red texture to the material’s SpecularMap, there is no red glow or anything. I tried with other colors - with no luck. Any help?

you are not newbie so i understand problem is more advanced. but i got no other ideas like:

do you have diffuseTexture too? or maybe try to modify shiness(maybe its just too big / too small).

or your specularMap have too low contrast.

The specular is 512X512. I also have a diffuseTexture. I changed the shininess from -1 up to 1. Nothing changed - except that fro 0 to -1, part of the model started to disappear.

if you could share material, maybe i will have a luck to find a problem.

[java]Material Bump : Common/MatDefs/Light/Lighting.j3md {

MaterialParameters {

VTangent : false

HighQuality : false

LATC : false

UseAlpha : false

VertexLighting : false

Minnaert : false

UseVertexColor : false

SteepParallax : false

UseMaterialColors : false

PackedNormalParallax : false

EnvMapAsSphereMap : false

SeparateTexCoord : false

LowQuality : false

WardIso : false

Shininess : 1.0

NormalMap : Textures/Main2.jpg

DiffuseMap : Textures/Texture.jpg

SpecularMap : Textures/Glow_1.jpg


AdditionalRenderState {

ColorWrite On




Is the source enough?

Shininess can go up to 128 if i recall correctly.

Not 128. I put 1,000 and it worked. However, still no red glow where the light hits it. I’m using a point light, if that makes any difference.

post a screenshot


Not a hint of red.

i can’t belive it dont work, but i have same issue.

maybe i forgot about something…

You have to set UseMaterialColor and set a SpecularColor.

You misunderstand how it works. I admit it can be confusing though.

Specular color define the color that will be reflected, the specular map defines the shininess intensity.

usually it’s a grey scale map

look at this example :


i just took the Elephant model, removed the normal map for the example.

Added a red specularColor and checked UseMaterialColor.

Then i added this checker specularMap


Notice that the red specular color is only visible where the checker is white and invisible where it’s black

The shiniess Factor define how hard is the shininess

Nothing happens if I don’t check UseMaterialColor. However, when I do the spatial becomes totally black. I am using a totally white and a totally black Specular texture for two different spatials.

you have to set the diffuse color to white.

Look at how my material is configured

That was the mistake I was making. Another mistake I was making was setting the Shininess too high. Thanks.