Strange dds loading problem:

Well i have a model, with a material, however depending on if I write the dds file in the .material file, or the .jpg it looks different:

with jpg:

with dds

in the second when i move nearer with the camera it slowly gets more visible, kinda like when the cam farfrustrum i to low. However I only changed the extendsion from jpg to dds .

Here is the used model, if someone want to take a look at it:

(the small download button on the bottom is the real one the other is jsut an add)

The jpg is actually generated out of the dds, so I think the dds is fine.

BTW: here you see the first screenshot of the result my textureatlas compiler for jme/ogre generates (both models are actually already remapped,they included two seperate textures in my model programm)

the NvidiaAtlasTexture tool

I dont know much about dds, but hasnt it got some kind of LOD worked in? So that you have different textures for different distances? I guess then some textures for certain distances are missing in the dds?

Just a guess…

Hm you are right, i found a command to disable mipmap generation wich solved the problem.

Texture atlas material system is nearly to alpha then.

I think there's something wrong with the mipmaps of the texture (maybe they are all black?), because when I disable them it works fine. What tool did you use to generate the DDS file?