Strange error when importing ogre mesh.xml from 3DSMAX

I have been using JME and 3DSMAX off and on for years now. I am trying to just import a very simple model using the ogremax exporter (something I have done hundreds of times without fail). For some reason I am now getting this warning:

May 07, 2014 12:31:53 PM com.jme3.scene.plugins.ogre.MaterialLoader readTextureUnitStatement
WARNING: Unsupported texture_unit directive: transform

It doesn’t throw a error at all just this warning, and then it precedes to add my model to the world but it is invisible. If I manually set a simple material on it like so:

Material mat = new Material(assetManager, “Common/MatDefs/Misc/Unshaded.j3md”);
mat.setColor(“Color”, ColorRGBA.Blue);

It shows up, but obviously does not have any of the textures or mapping I applied in 3dsmax. Importing has worked for me without this problem int he past, has anyone come across this.

– As a final aside I have tried having my materials exported into separate files and I have also tried the single file option. My textures are located in the same assets folder as the model. All in all I am doing everything the same as I always have, this error is just coming out of nowhere. I was using the last build available on the site, and I have since updated it to the nightly build and it has changed nothing :frowning:

Maybe you in fact changed one of the myriads of options in 3DS?

Hahah no joke there is a plethora of different options. I have sifted through them and nothing jumped out at me as wrong. I will triple check my settings and get back to you. Considering I seem to be the only one with this issue, it must be something on my side.

Sigh, every time I think I “get” JME. I am just reminded how little I know. I was unaware the ogre importer used Lighting.j3md as it’s default matdef. So… No lights in the scene means no model showing up. Thanks for your time Normen, as always. Sorry for the bother.

1 Like