Strange for new jME compile

I just checked out the latest jME from CVS. I’ve been using a couple week old version for awhile. As soon as I ran I noticed that it seems to be in software rendering mode instead of Hardware… bad textures with very bad framerates. I don’t know what’s going on. Any help on recent changes?

Nope no go :(!



I’m using only a few textures… but using them many times.



As far as non-compliant behaviors… I’m not sure. I haven’t really changed anything as far as basic initialization for awhile.

A little more specific please? :slight_smile: No go on your app, or did you try the tests?

Sorry… the problem is consistent even in the Test apps. I see it really well on the font textures.

Hmm, sorry if you’ve mentioned this before (couldn’t find it with a search of the board) but what are your exact system specs(OS version, Card version, driver version, processor and ram)? Have you tried upgrading your drivers? Also important, do the webstart demos still work fine? Finally, can I see a screenshot or two of this issue?

Sure:



Old jME build:



New jME build:





Notice the fonts… but you can also see it in the textures themselves.



I’m using a Radeon 7000 series, pretty old, with up-to-date drivers. They don’t update very often for a card this old. (ATI Tech, 6.14.10.6387, 9/12/2003)



Win2000, Intel P4 2.5 GHz.

Webstart works ok? It appears to be a filter issue. If webstart works ok for you, that would be a good clue.

Webstart apps from the demo area work just fine.

guurk, please try with the change I placed in cvs. It eliminates an optimization having to do with filtering. I can not think of any other change that would make a difference.

I can’t compile the jME in cvs right now so I can’t check it out. I’ll try later.



However, this may be a good time to discuss starting to use branching within CVS to handle all the new development threads. If we lay some ground rules now we can aleviate a lot of headache. I’d wish that only working / regression tested code would be merged into the HEAD. Maybe even using some per-developer labeling? Does anyone agree?

I’m not sure we need something like that. Changes that we’ve checked on a few platforms should be okay to check in… it’s a work in progress after all. Yes, older systems will crap out on newer features as we add them, even if we’ve checked them on our development boxes… but unless we get someone like you exposing that, we’ll never know about them to add in multiple paths, etc. :slight_smile:

I think that JME should have the options to turn off on newer features for ollder computers or JME would be usless for games.(Almost all modern games run on computers 3 years old by having this.)

For what it’s worth my newer system here at home works fine with the current CVS build.



I’ll double check at work tomorrow.

Very strange… I guess your change, renanse, made the difference for the textures, but I’m still getting really low FPS here with this older card.

Is anyone else experiencing this? I have not yet gotten my computer back up at the house, so I haven’t touched CVS in over a week. I also can’t download jME to the work computer as they would kill me. So I’m unable to test.

Just a little more info… I’m rendering a scene with 1 major mesh with 60K+ triangles. I also have a little debug info for frame rates and such, and the mouse pointer.



With the old jME I was getting 30+ frames per second with this old card.

Now I get about 7. I turned off all logging except for SEVERE and it went up to about 8. I don’t really see the pause here, I think because the pause is so long that it’s no longer just a pause but rather a frame rate inhibitor.



The pause does happen in all the test apps within jme as well.



When I just show the frame rate stuff I get 100 frames per second (I throttle them there) and when the pause happens they go down to around 80.

After looking back through the code… I notice that renanse made a change in LWJGLRenderer b/t version 1.25 and 1.26 that changed:



GL11.glDrawElements to GL12.glDrawRangeElements



I changed it back locally and I regained my framerate to 30+.



TestMultitexture is also now MUCH faster… from 30 frames per second to over 60.



I have no idea what the difference is however :? .

I’m updating my driver… from what I’ve read using the ‘range’ version should actually speed things up. They released a new driver yesterday :).

hehe, was just about to say the above. :slight_smile:



PS: using ranged helped the newer nVidia cards triple their frame rate in jME when using VBO. Other cards had higher rates as well, but not quite as dramatic. My only worry is that your card can’t support ranged due to some hardware reason…? How old is radeon 7000 anyhow??

First 7000 series shiped Jan 2002.



They use them here because they are made into fairly inexpensive 2 head card.