Strange playback of sound effect

Hi all,

I tried getting into jMEs way of playing sound effects, but somehow it doesn´t work well…
I have a simple audio sample (.wav format, but it happens with other samples in the .ogg format too) and while it sounds pretty normal when playing it with windows media player, winamp or audacity, when I play it with jME, the sound is strangely distorted.
Too bad I can´t upload the original sound and a recording of the actual here but it sounds a bit like there may be little pauses in between… or somehow there was the wrong frequency used… or maybe even vibrating? … it´s hard to describe.

So that you have as much info as possible: It´s a mono audio file, 11025Hz frequency and audacity says 32-bit float.
The important parts of my code are here:

private AudioNode audio_step;
private long timeFootstep;

public SoundManager(Main m) {

private void initSounds() {
    audio_step = new AudioNode(m.getAssetManager(),"Sounds/step.wav",false);

public void playFootstep() {
    if (System.currentTimeMillis()-timeFootstep>1000) {
        timeFootstep = System.currentTimeMillis();


playFootstep() is called from time to time by another class.

Do you know what I could be doing wrong?
Or maybe you have a guess on what should be tested?

Thx in advance

Can you record both sounds and host them on one of the online upload-your-music sites? (Even youtube would work).

sorry, it took some time to reply since i just had a finals exam yesterday

anyway: I uploaded a video to youtube, demonstrating the difference in the sound:
[video]- YouTube

Now you should be able to distinguish the difference.

sounds like echo , reverb or something like that for me. For test does that also happen when set to non positional? What happens if you change the echo reverb filter ect paramters in the audionode?

Yeah, I agree with empire, that sounds very much like environment effects being applied to the sound to me too.

I want to say that reverb is on by default and that the default environment settings are ugly. My memory is fuzzy but I sort of remember specifically turning reverb off on every AudioNode I create.


ok, I checked it and you are right, of course;
its the reverb causing this effect.
I now use Environment.Cavern and it sounds different too, but not as bad/weird as the outcome of that default setting.
Maybe I should´ve read more about audio beforehand; but still thank you.