Strange scale of a model from the FBXLoader

I tried to load the same model from .blend and .fbx formats. When I load the model from .blend format, the loaded model has correct scale, but if I load the same model from .fbx format the loaded model has x100 scale. For example a standard of SDK model:
The model from .blend:
The model from .fbx:

Did you apply all transforms before export?

As I recall, the .blend loader tries to be somewhat compliant to transforms (though it’s hit or miss and very version dependent.) Perhaps the FBX exporter (or importer) is not as kind.

I just opened the model in the Blender and exported one to fxb without any actions.

Well, you should apply all transforms for sure then.

It didn’t help me.

Can you test with Apply Transform option checked, on export panel

I have checked this option and I have the same result :frowning:

Hmmm, strange …

Maybe @Eirenliel can help with this. She reworked the FBX importer for JME.

You need to either scale model after loading to JME or set units in blender to centimeters (idk if blender have this option). No program out there properly uses scale information from FBX…


Do you know how to do it?

You can set units in blender as below

1 Like

It works, thx :slight_smile:

Unfortunately the FBX loader currently ignores the units, so if you have things in meters, it will scale it up x100.

1 Like

It’s not a loader’s problem, it is never used in FBX for this purpose.

Btw, I made a few very cool tweaks and fixes in the FBX importer and will commit them on holidays. Some things were very-very untested…