Stuck task in jmonkey platform


When I load jMonkeyPlatform I can see in the bottom right corner “Opening SceneViewer”, but it is always stuck on 14%, and if I click on it nothing happens. What is this? The things I have tried so far with this excellent tool have all worked well - although I have only tried editing, compiling and running code so it doesn’t seem to cause me a problem for what I need but obviously something has gone wrong.


The scene cannot be started properly, can you view models in the SceneViewer? You can try by downloading an AssetPack (dont forget to turn on the light).

Yeah, I had this same problem. This is why I reinstalled. I couldn’t view any models or edit them or anything. Open a different project and still couldn’t open any models. No SceneViewer window or anything. Just the 14% bar in the bottom corner.

This is not a bug in jMP but rather a problem with the graphics/lwjgl subsystem. Somehow your graphics card doesn’t like whats happening on startup… Can you view the examples? Like in the webstart from for example? Also make sure the SceneViewer is not hidden on start.

I couldn’t see anything. It’s not that the window was minimized or all black, it was just not there at all. I’ve reinstalled and fixed the issue, but not entirely sure what caused it.