Target "debug" does not exist in the project


I am trying to follow the tutorials and build an android project in jmp. When I try to run it I got an error saying Target “debug” does not exist in the project. How to I get past this? Thanks.

I have a similar issues when I Run an example-Project:

“Importing rules file: toolsantmain_rules.xml

E:…jMonkeyJmeTestsnbprojectmobile-impl.xml:6: The following error occurred while executing this line:

Target “installd” does not exist in the project “JME3TestsTemplate”.”

in line 6 of the file mobile-impl.xml:

I simply want to test an example on my SGS2. Not sure if the IDE detects the device over USB or not. Just can’t get

beyond this build error.

When I only Build the project then the process is finished SUCCESSFULLY.

Can anyone helps us?

Update the SDK (and Android SDK) and update the android project, this should happen by going to the project “mobile” preferences panel once. Else rebuild it by deselecting android deployment and then press OK, after re-enable it, this will delete and rebuild the mobile folder with the Android project.

Thank You, for your fast Reply.

All SDKs and android Project are up to date, now.

Also the mobile folder was created, but now without the

When I copy and want to install the example-unsigned-release.apk-built to my phone,

it says that the Application wasn’t installed.

Also I tried to run the app directly over USB-Debug-Connection - no success.

Is there a tutorial how to run your jme3-apps on your android phone directly?

How can I setup the Android-device for jMonkeyEngine-IDE?

Any ideas or links?

Yeah, its described in the manual, you just use the “Android Device” run configuration.

mmh, I’ve already tried this - several times.

When I select the Android Device run configuration

it shows the same desktop-execute-window like in default-run-config-mode.

Maybe I’ve destroyed some properties by customizing the run configuration.

But even a complete reinstallation of jmonkey doesn’t help.

Also I’ve tried an example of the Android 3D Engine “jPCT-AE” in Eclipse.

The jPCT-AE-example runs without any errors on my device.

Maybe I’m going to try to integrate jMonkey in Eclipse.

My target is to port a 3D-Game to Android, but I don’t want to start completely from OpenGL-scratch.

That’s why I was searching for a Android 3D Engine and found the jMonkeyEngine.

Is jMonkey practical for this topic?

however - thanks for your Replies again. I’m trying my best to getting started with jMonkey.

Hm, there were some changes in the Android SDK recently and we had to adapt the build scrips, thats why I mentioned updating both SDK’s and recreating the project. The “Android Device” target should work though and definitely not start the normal desktop app, make sure the project is selected as the “Main” project.

Updated Android SDK, JME3 SDK and recreating the project like you said,

also the project is selected as the Main project.

This “Android Device”-run config-mode issue is very strange especially as

it was already working today…

i guess it’s “error 14 - the problem sits before it” :smiley:

i’m going to try some more…

thanks for your help

Would be nice if you could check into this. I don’t have an android device so I cannot test this all 100%. The build stuff is mostly done in nbproject/mobile-impl.xml, if you have some fix for it or something please let me know. Btw, you should be able to open the project thats in the “mobile” directory in Eclipse as well, so maybe you can test it there too and see if theres issues. The main project has to be built once to get the libraries into the Android project, after that its a “normal” Android project.

Hi, yesterday I got a simple android project working with jmonkeyIDE. The device is shown in the service-explorer next to the file-explorer on the left side of the IDE. So I think there is no problem with the device connection. Later or tomorrow i will try to integrate a simple jme3-project into eclipse. Maybe this will bring us to a solution… Stay tuned and enjoy skyrim :slight_smile:

Got Basic-JME3-Example Working on Android-Device by doing the following:

1. Develope JME3-Application:

  • Create new JME3-Example in jMonkey-IDE
  • Build Main Project for Android-Devices (see Android deployment manual: set Android-sdk, let jME-IDE create the mobile folder, build Main-Project)

    2. Port JME3-Application to Eclipse:
  • Create new Android-Project in Eclipse (import function doesn’t work with the newest Android-Eclipse-Plugin, too bad :/)
  • Link the generated JME3-libaries to the new Android-Project in Eclipse
  • Paste the MainActivity-code from the jMonkey-Project to the MainActivity of the Eclipse-project

    3. Run JME3-Application via Eclipse:
  • connect Android-Device via USB-Debug to your PC
  • Run Eclipse-project as Android-Application

    With this workaround and the newest updates of all SDKs, you can run your JME3-Application on your device

    without getting the Error “Target ‘debug/installd’ does not exist in the project”.

    Nevertheless I will be happy if the run-on-device-function is available soon in jME-IDE.


I am convinced that somethings not updated in your setup. The eclipse plugin and the SDK updates are released about the same time, so that the import fails hints at other problems. With the latest updates installed, I can create a BasicGame project, enable android deployment and then see the application being installed on the emulator when its started…

Does your Android SDK manager look like this?

Thats the new UI after the update.

yes, my Android SDK Manager looks the same

@kbjansen said:
- Build Main Project for Android-Devices (see Android deployment manual: set Android-sdk, let jME-IDE create the mobile folder, build Main-Project)

I don't understand, when this works then android deployment works. What are you trying to do? oO The "Android Device target runs normal Application" problem was solved by another user by updating his android SDK, so idk whats wrong on your computer :/

ok, the problem is that when I choose “Android Device” in the run configuration list then I get the same application window like when I choose

“default”. My thoughts are that the application is sent to the connected device when I choose run via Android device.

The SDK-updates does not help on my system.

The JME3 building process seems to be completely perfect. The packages that are generated work very well while compiling the Android application

with Eclipse. When I look under Project > Properties > Run the configuration of the Android Device looks nearly the same as the default-config:

Is that right?

Yeah, thats ok. In nbproject/configs you see what the target does, it mainly changes the “run” and/or “build” targets, you cannot see that in the config window.

To run the application with that configuration, make sure the project is selected as the “Main” project (right-click, select “Set as Main Project”) and then select the Android Device configuration in the top bar:

Seems to work for me and others :confused: What is the version of nbproject/mobile-impl.xml on your computer? It should say:

[xml]<!–mobile-impl.xml v0.12–>[/xml]

Jo, the run config is activated, sure. The version of mobile-impl. Xml will be checked by me tomorrow. Maybe I capture a video to show you what I’m talking about - I think that would be better.


Else you can also right-click the build.xml in the “Files” view and select the “run-android” target:

I was now able to reproduce the behavior that it won’t run the run-android target when the configuration is selected but I don’t know what causes it yet. Running the run-android target directly as described in the previous post works though. Also the normal build creates the apk file as expected.