Target "debug" does not exist in the project

ok, when I run the build.xml in file view like you said (via right click) then the project gets installed on the device after few seconds (a lil success! :D).

But when I run the installed application on the phone then it crashes. :confused:

If I try to install the apk that was built under normal configuration (right click build in project view with android device selected as run config)

then it says that the application isn’t installed:

“Application not installed”

Any idea why?

How does it crash? Log? Exception? I think you have to enable unsigned applications somewhe in your phone.

Arrg now I can remember… Android Apps need to be signed. It doesn’t work if you only enable the

“settings > application > Allow Installation of non-Marked application” option.

You have to self sign the app, but it’s not very difficult:

How to Self sign Android Apps

I’d forgotten that cause every time you test an app with Eclipse via USB-Debug

Eclipse automatically sign the app with a development-key.

So Self-Signing is a solution to get the apk work on your device when you build the project with the jMonkey platform.

Thanks for your help Normen!


1 Like

Hm, but the debug target should self-sign the debug version automatically… So you just created a keystore and referenced it in the local file? Or did you use the NBAndroid projects settings for this?

oh I see. You are right! The debug-signing is set to true. That is why the debug.apk was successfully installed via USB-Debug-Connection.

The problem why the application crashes with: "The application MainActivity (process com.mycompany.mygame) was unexpectedly terminated. Try again " has to be another one.

For self signing I would create a keystore manually and paste it to the app.

How can I use NBAndroid for self signing?

You can open the project in the “mobile” folder and should be able to access signing settings via its properties.

@kbjansen: I now know why the “Android Device” doesn’t run the app on the device… Its when “Compile on Save” is enabled in the project… The checkbox even says so :wink: D’oh xD

Oh o.O thanks! I will try to disable this option tomorrow. Bad news are that my device (sgs2) does not support all the features of jMonkey D:

I had problems with the 3rd tutorial ( )

No lights, no terrain, sometimes no models (see ninja example - link above)

So, now i have to use engines like jPCT, libgdx and mages for my project. Too sad :confused:

But thanks for your help normen.

@kbjansen: I dont see any problem solving attempts in that thread, did you try changing the configuration to FASTEST in the MainActivity? Checked what kinds of materials cause these issues? Ninja etc all use lighting material, I guess Unshaded should work without issues (and is probably better for android devices anyway)