Terrain demo framerate slows to zero in linux

im running jre1.5 (i also tried 1.4 and still had same problem)

latest jme from cvs

athlon xp 2500+

radeon 9800 pro

512m  memory

debian testing linux

the test terrain page demo runs great at over 300fps all the time but all the other terrain demos are extremly choppy on startup and quickly slow to zero fps.

most of the demos work great, the skybox demo is smooth until i get the 3 objects floating in the sky into view then it slows WAY down until i move cam away from objects.

any help would be appreciated, thx

Does the test terrain page demo ALWAYS run at 300+fps? Or just the first time you run it? I discovered that I had at least one rogue Java VM processes left over from previous demo runs, which would drag the FPS down to zero. Do:

ps -ef  | grep java

And make sure you don't have any rogue processes. Otherwise, sorry I can't help!

So you don't have any other Java VMs lying around by the looks of it. Hmmm. I'm really confused now. I was going to suggest leaving "top" running while you run the demo, but that wouldn't account for what you're seeing.

What desktop/window manager are you using? Can you try a different one? For example, try FluxBox or FVWM or something else that's easy to setup and minimally intrusive on your PC?

Wow, there certainly seems to be a lot of problems in Linux suddenly. Which is very strange, as you know I'm using Ubuntu and had no problems and have made zero optimizations (other than installing the full nvidia drivers).

I'd like to figure out what the common connection is.

It's odd that we're getting these problems. I really can't think of any reasons why, other than rogue Java processes killing FPS.

It all worked for me under Fedora Core 4 with GNOME, so I'm not sure if it's relate to using KDE. I use NetBeans, he uses Eclipse. I don't know what desktop he uses - he hasn't verified that.

I wonder if it's related to X in some way.

I was using gnome so i tried fluxbox and no change.I seem to remember when i first tried jme at the .8 release these demos worked fine. I will try .8 release again and see if it works later today

Is the slowdown there when starting the terrain demo from webstart as well?

yes I get same results starting from webstart. the terrain pages demo runs smooth but the others are very slow. even when it says 45fps i cant move the camera it seems to run under 1fps. i have to hold down the esc key to get it to close.

I know, stupid question time, you are certain you have the "nvidia" XFree86 driver running and not the "nv" one?

i have ati radeon 9800 pro with fglrx driver ver.8.16.20-1

also have xorg 6.8.2

Run glxinfo and make sure Mesa3D isn't listed.

Well that must be your problem - a rogue Java process is hogging CPU, which means when you subsequently run another JME demo, the FPS quickly drops to zero.

Are you sure you can't kill the rogue process? If you have one, exit all JME demos, and do:

ps -ef | grep java

If there is a rogue process, kill -9 followed by it's process ID number should kill it. This is the exact same problem I had.

Try removing all directories in ~ that have ICEauthority in the name and then reboot. I don't promise that will solve the problem.

Also, before doing kill -9, try kill -3 pid. It may give clues.

I should have been more clear…if i run TestTerrainPage with no rogue processes running it runs fine.If I run TestTerrainPage with rogue process running it runs slow.If i run any other terrain demo or the skybox demo with NO rogue processes running it still runs slow. so i have 2 problems going on here. 1.terrain demos wont run properly and 2.they also leave rogue processes running on my machine.

The differences between TestTerrainPage and the other terrain demos may be a clue to the problem but im too much of a newb to figure it out.

edit: i tried same demos in windows and they worked great, next i want to try nvidia card in linux cause ati drivers in linux are crappy and may be the problem .i'll post results.