TerrainGridTest problem

Hey, I’m trying to learn a bit about endless terrain but I’m having trouble running this http://code.google.com/p/jmonkeyengine/source/browse/trunk/engine/src/test/jme3test/terrain/TerrainGridTest.java test class. All I get is a blue background, and the number of triangles or verticies doesn’t change wherever I move. I had a look and noticed that the ‘file’ variable, a .zip it loads at the start of the class, is not used at all withing the class, so I took out the whole IF statement, run the class & the terrain appears but everything is black… add it back in and nothing works again… Lolwut?

P.S tried adding in some more light, no change :stuck_out_tongue:

I’m actually using all the libs from the nightly, orginally I didn’t have the TerrainGridLodControl in my libs so I had to use the nightly libs.

Move down a bit.

I’ve tried

EDIT: also tried adding in a cube so I can see where I am, the terrain just isn’t there.

I can’t see anything either.

How do we get terrainGrid up? the fractal map test works but I need to use heightmaps. The alpha map test also works but I get black ‘liquid’ over ererything, & when a new section of terrain loads there is about a .8 second lag from the whole game http://code.google.com/p/jmonkeyengine/source/browse/trunk/engine/src/test/jme3test/terrain/TerrainGridAlphaMapTest.java

It appears the assetLocator isn’t downloading the zip file. You can download it manually for now at http://jmonkeyengine.googlecode.com/files/TerrainGridTestData.zip and place it in your root jme directory, then the level will show up.

I will take a look as to why the locator isn’t downloading the data file.

As for that lag, that is new… I will have to dig through some of the latest commits and see what affected it.

EDIT: that lag is caused from it not finding the alphamap images, so if the zip file is there (containing the alpha maps) the lag is gone.

Right, ok thanks ill try it

EDIT: perfect! thanks @Sploreg

EDIT: am I still supposed to be getting this black ‘fluid’? The reason I say fluid is because it moves when I move, in a liquid-ish fashion.


This is only on the Alpha test by the way

oh, um that looks weird. Normally that means it is missing tangents, but terrain generates those automatically for you. The rest of the textures look messed up too. Maybe try updating your video card drivers and see if that helps it.

Looks to me like someone else got stuck with an Intel GPU :stuck_out_tongue:

Nvidia actually, looks like my drivers are up to date, don’t know what this could be caused by i’ll test it out on linux later

Set it like that TerrainMaterial.setFloat(“Shininess”, 0.1f); and you’re good, if the material you use is TerrainLighting.

Something funny is going on, when you leave the shininess to the default material parameter you get a really bright result… someone did some changes in the Material class, or renderer?

Yea it had to be changed a while ago to support some older video cards. I will see about having it default to zero again.