TerraMonkey Questions

So I did a clean install of alpha4 the other day and I’m really enjoying all of the updates! Thank you all for all the work you’ve done. I only wish I was skilled enough to help. One day, perhaps…one day…

So I’ve been fooling around with the new terrain editor and I’ve noticed a few behaviors about it that I believe are either not supposed to happen, or aren’t very intuitive and should no longer happen.

I am running Alpha-4 on a macbook (OSX). All of these involve creating a blank scene and adding a terrain via the terrain editor window. (in case there is another way to utilize this window that I am not yet aware of)

  1. I’m almost positive I’m not supposed to be getting an exception error when I add another texture to the terrain:

  2. I can still add the second texture after the error is thrown, but it never saves anything I paint no matter how much I try. It will usually last until I close the program, however.

  3. If I close the program without saving, the window that asks me if I want to save will not have any buttons to chose. Likewise, the interface of JMP disappears and I have to force close the program. This happens more than half of the time.

  4. I tried making a blank scene, adding a terrain size 256, editing it a bit (successfully), offsetting it by 256 in the x, adding a second terrain, and attempting to edit as though they were one. This wouldn’t allow the green icosphere to “cross over” the boundary between the two terrains onto the second terrain. This may be by design, but I was also unable to edit either terrain any more either.

  5. BEFORE adding the second terrain into the previous scene I made a second empty scene and added the previous scene into it as a model. So now I have the first scene with one terrain model, and a second scene with the first scene inside of it. Adding a second terrain to the second scene produced the same effect as in (4) except that I could still edit the first terrain. However, changes made to the height of the first terrain inside of the second scene did not carry over to the original scene. Again, this may be by design, but texture changes using the spray can DID carry over. Of course any changes I made to the textures only lasted until I closed the program. No matter how much I hit save or added another texture (in case it had trouble remembering the last texture added) it does not appear to remember the alpha map for any terrain I paint.

  6. After editing the first terrain in part (4) for about 10 min with the second one sitting adjacent and untouchable, I experienced a significant frame rate drop every time I clicked on the terrain to heighten it. The fps was fine as I moved my mouse around on the surface, but the second I attempted to change the height it almost completely freezes; additionally, while it is frozen, hardly any effect from the brush is seen.

  7. Lastly, if I tried to load a basic terrain scene into the game with the default dirt texture on it, the engine throws an error. Not a big deal, it just doesn’t say anything about needing to change that texture. I figured it out though.

    Thats all I’ve seen so far. Like I said before, some of these may be by design, but if they are I think they should be more intuitive or at least pop up and tell me why it’s doing something. Thanks again for everything!

If the alpha maps aren’t saving then a bug has snuck back in. I will take a look and see what is going on.

The alpha maps are saved into your assets/textures/terrain-alpha/ directory, so if that is available to your game then it should be able to find them.

Hm, I think the problem might be that they are not being saved when I close. As I stated before, I frequently get the box offering to save but end up having to force close. I just induced it purposely and sure enough, it’s offering to save the alpha but I can’t. Is there a way to tell it to save the alpha map before closing the program? Because hitting save doesn’t seem to work.

Also, if I navigated to the alpha png files in Finder and viewed them normally am I supposed to see the color coordinated map? Or are they just storing the data quietly?

Ok I think this bug has reared its head again :frowning:

It definitely should not crash when the save prompt comes up. What OS are you using?

You won’t be able to see anything in the alpha images unless you have painted in the 4th texture layer (the A in the RGBA layers).

Running OSX 10.6.7

Hm, ok so I was under the impression that the alpha map was the colored map that told the other textures where to go. And that part of the point of TerraMonkey was to remove the need to draw your own alpha map, instead having it generated based on how you paint the terrain in the GUI. Is this not correct? If so, then why would I not see the RGB of the first 3 textures in the alpha map?

These saving issues definitely seem to happen more on macOS.

Yes that is what the alpha map is. The editor saves you from having to manually edit the alpha maps.

You will not see the RGB values of the image if there is no alpha. So unless you paint a 4th texture layer the terrain editor, you won’t see the first 3 layers in the alpha map. They are there, you just can’t see them as an image in an image program.

hmm, 2 terrains. I hoped someone wouldn’t try that just yet :slight_smile:

Yes more than one terrain is not supported by the tools yet. For now I will change it to have the ‘add terrain’ button grayed out if you already have a terrain added in. Having the two will no doubt cause lots of issues with the tools right now.

Haha ok, I figured that was what was going on. Any idea why my alpha map doesn’t seem to be saving? I forgot to mention that it doesn’t show anything I paint in game either. The terrain is just my first texture solid across the whole thing.

Ah ok interesting.

Btw, I just figured out (due to flipping out of JMP more than usual to post here) that the Radius and Height/Weight sliders work, but they don’t take effect until I switch windows and come back. Weird…

That is another issue only seen on mac, possibly linux too. It is being looked at this week.