Test cube looks good in SceneComposer display, but not in jME


I made several test cubes with a different UV method applied to each test cube. All of the cubes look good in the SceneComposer edit display, but some of the faces of the cubes are missing the bitmap face image.

The material file was named the same as the cube file and was copied to the same directory by the ogreXML export.

How can I get the testCube.j3o to look as good in jME as it does in the SceneComposer display?


Do you have a light in your scene?


Yes, There is a light in the environment. I can view some of the bitmap images on some of the faces, but other faces are black, not too dark to see, black.


If you use a lighting material, be sure to generate the tangents for the mesh, see TangentBinormalGenerator.


Thanks for the feedback.:roll:

I have continued to test models made with both Blender and 3dsMax. 3dsMax is working best for UV textured models, for me. Like I stated before the models will look great in the Scene Composer. The models have complete texture UV mapping in tact when (viewed/edited) in the Scene Composer, but when displayed in the engine one face will be missing the texture. One face of the model will be black. The scene is properly illuminated. The TangentBinormalGenerator option did not help.

In my reading over the free, 3dsmax OgreXML exporter software documentation I noticed the following limitations.

Only one texture coordinate set will be exported per mesh.

Only one texture unit will be exported per OgreMax material.

Is it possible that one of these limitations is the source of the black face on my models?

When updating the jMonkey from nightly I often see Blender Support updates included. Does the Blender Support update indicate that the export scripts have been updated and that the Tools > OgreXML > Install Blender OgreXML needs to be launched and the process will copy a new version of the OgreXML export scripts in Blender?

I also noticed that the Blender OgreXML export does not name files as it previously did. I have to rename the scene file with a ‘.scene’ added before jMonkey will recognize the scene file. The material file is also missing the ‘.material’ when exported.