TestRenderToCubemap only renders on one of the sides


#21

When I run the JME test, no matter where I look, I see cubes everywhere:

In all directions, cubes.

jmonkeyengine/gradlew run
Search for cubemap and then run it. Cubes everywhere.

If you do not see cubes everywhere then it must be something about your AMD card/drivers.

Edit: if you did see cubes everywhere until you modified something… then your modifications broke it. Then we can look at why.

…but it’s still unclear to me if the original test even worked for you.


#22

I have never seen cubes everywhere neither in that test, my slightly modified test, its only ever shown on one of the faces of the cubemap.

My graphics drivers are as up to date as they can be (specs are listed in an above post), honestly a really common combination. But i guess that is the problem.

Thanks for showing me what the test is at least supposed to look like.


#23

It’s quite common to have to back-rev AMD drivers to get things to work properly. Their driver writers have gotten better (used to be total shit)… but still not great I guess. (now maybe just mud with some shit in it).


#24

Oh wow, didn’t realise that the drivers could be so ‘brittle’.
I have now updated to the latest pre-release version just to check if its fixed - was not, awesome.