Textures not loading properly in LWJGL

When I run any of the jmetest demo's that have textures in it, in LWJGL mode as opposed to JOGL i get a "java.lang.ArrayIndexOutOfBoundsException: 0" on line 65, "app.start();" Is anyone else having this issue? Also the problem seems to trace to G11.java line 2986

have you included the native library? for jinput.jar ?

Yes I have. I have all the included jar's and necessary native's setup

Wait… sorry no i dont have natives for jinput… where does that live?

the native library are in the directory of lwgl in “native” Choose the directory that-responds to your Operating System

Yes thats included, could it be anything else?

a version ?  jme  ?  lwgl ? 

you have last download ?

your graphics card ? is ?

Yes i have the latest version of everything. And my graphics card is Radeon Xpress 1150. It says that it cant access an array at index zero ( 0 ) … so maybe something isn't being initialized? it works in JOGL mode though

you have the problem for all Jme test ?

Only ones with texture loading in it using LWJGL

give me the exact name of the "package" file and execute example jmetest.ogreXml -> TestMesh Loading

which package file? And i get the same error running that example. Is it because im running in software mode?

System.setProperty("org.lwjgl.opengl.Display.allowSoftwareOpenGL", "true");

not the package name and class you try to launch


is run great with me

do you think it could be because im running in software mode?

i don't know

java.lang.ArrayIndexOutOfBoundsException: 0

at org.lwjgl.opengl.G11.glTexCoordPointer(G11.java:2986)

at com.jme.renderer.lwjgl.LWJGLRenderer.predrawGeometry (LWJGLRenderer.java:1502)

at com.jme.renderer.lwjgl.LWJGLRenderer.draw (LWJGLRenderer.java:999)

at com.jme.scene.TriMesh.draw(TriMesh.java:240)

at com.jme.renderer.RenderQueue.renderOpaqueBucket(RenderQueue.java:249)

at com.jme.renderer.RenderQueue.renderBuckets(RenderQueue.java:237)

at com.jme.renderer.lwjgl.LWJGLRenderer.displayBackBuffer(LWJGLRenderer.java:521)

at com.jme.app.BaseGame.start(BaseGame.java:90)

at jmetest.ogrexml.TestMeshLoading.main(TestMeshLoading.java:82)


did you find a solution? I have the same problem…