Textures

Hello,

I'm exploring the Jmonkeyengine for a project at school.



but I've stumbled on some errors which I can't really place. I hope you can enlighten me…



        Texture t1 = TextureManager.loadTexture(pt.getImageIcon().getImage(),

                Texture.MM_LINEAR_LINEAR,

                Texture.FM_LINEAR,

                true);

        ts.setTexture(t1, 0);



The "MM_LINEAR_LINEAR" and "FM_LINEAR" are underlined



and also

terrain = new TerrainPage("Terrain", 33, heightMap.getSize(), terrainScale, heightMap.getHeightMap(), false);



here the "TerrainPage" is underlined



Thanks for reading

  • feed

you are using jme 2.0 libraries and the cod you posted is jme 1.0. search the wiki for the changes from 1.0 to 2.0 and use examples that are from and for jme 2.0  :wink:

Thanks alot for the fast reply, I'll look in to it asap!!

Hi People. It's my first post here on jME Forum o/.

I'm trying to learn a bit about this engine through jME wiki but I'm having some problems with the textures.

Every example which envolves textures, I just can't run!

When the program starts, my OS shows a message sayin that the app stoped working!



I don't have an offboard video-card, but I don't know if this is the reason of my problem. I'm using the jME 2 at Eclipse Ganymede.



Can someone tell me what's happening and how to fix it?



_________________________________________

sorry for the bad English. I'm Brazilian

 

Well texturing should not be a problem with onboard graphic cards  :wink:



You should update your graphic card driver, thats propably the reason.

dhdd said:

Well texturing should not be a problem with onboard graphic cards  :wink:

You should update your graphic card driver, thats propably the reason.


+1

FYI, the better known term for 'offboard' is dedicate graphics card (or 'discrete'), some people can be picky about computer vocabulary..