Texturing in Blender


Ive tried to follow several tutorials on how to apply texture to a 3d model, but none of them have worked succesfully. The one that ive been most satisfied with is this: http://www.youtube.com/watch?v=P_rklLJYhQg , which has resulted in a textured model, both in the workspace and when i render it in Blender, but when i try to load the model into jme, its all white and has no texture added. Ive uploaded my .xml-file at rapidshare. http://rapidshare.com/files/373513538/texturedbomberman-jme.xml.html

I hope some of you can help me out here with this problem.


You might have to add a resourcelocator to find your textures, see this post;

Hmm,…looks like there is no information about a texture is attached. Can you post your blend file as well

and I will have a look

The way to add texture in blender:

  • select mesh in edit-mode
  • unwrap mesh
  • in uv-editor load image (that is not necessary but so you can see the texture in texture mode)
  • add material
  • add new (texture)
  • map input->uv
  • in texture.mode(f6) set texture-type image
  • choose the image you loaded before (not press the button but use the two arrows)
  • uncheck "usealpha"
  • make all path relative (file->external data->make all paths relative)
  • export

Ive tried to follow your steps, but still no texture on the model. Im beginning to realize that i might be a noob, and thats the problem. Ive uploaded my .blend file at http://rapidshare.com/files/373778706/texbomberman.blend.html

Well, maybe your problem is that you want too much too fast(had the same problem).

Becoming comfortable with blender needs some time. Nevertheless your export should work.

Or let's say the problem is not the exporter anymore.

Actually it should work as long as "Bombermap.tga" is in the same folder as the hottbj-file.

Maybe we find a problem in your code (but normallly this just by loading it).

Here my exported hottbj-file. Maybe you find a difference!?

Placing the imagefile in the same folder as the model didn't help either. Do I have to let the code know which image I want to use, or is it included in the modelfile? Thanks, I'll have a look at your model later today.

I’ve tried to load your default-jme.xml in our project know, but he’s still all white: as you can see.

Here’s our code for the model loader. Do you find any errors?


public Spatial attachHotBJ() {

Spatial loadedSpatial = null;

XMLImporter xmlImporter = XMLImporter.getInstance();

URL objFile = TestObjJmeWrite.class.getClassLoader().getResource(


try {

loadedSpatial = (Spatial) xmlImporter.load(objFile);

} catch (Exception e) {

throw new IllegalArgumentException("Failed to load URL: "

  • objFile.toString(), e);


    loadedSpatial.setModelBound(new BoundingBox());


    return loadedSpatial;



When its just all white without shades the you dont have lights in your scene maybe?

I think before we guess all possibilities you pack your project (java-file,blend-file,texture-file) and post it as zip.

Turning on the light didn't change anything, but made the game look a LOT better. Thanks!

Here's the 3 files you asked for: http://rapidshare.com/files/375411005/Bomberman.zip.html

Our game is showing the testsphere and the 3d model.

Great link, but unfortunately I still can't make it work. I'm pretty sure that I've done exactly what you've told. Many times. The problem now is that when I try to export, there's no objects to export: http://yfrog.com/6timage1fsj

Well, maybe you should ask yourself why you have export 0.3xx when 0.4b is the current one! So option ine would be to activate use_alpha again (not sure if this really solves it) or to switch to the current exporter…


Sry, it was my fault to think that you use the latest version