"The JDK is missing and is required to run some NetBeans modules"

I’m running Ubuntu 12.04, 64 bit.

Just downloaded JMonkey and I really can’t solve this thing…

When I start jMonkeyPlatform I get this message:


I tried to download the SDK and running from jMonkeyPlatform from terminal as root like this:

sudo /bin/sh "/home/lorenzo/jmonkeyplatform/bin/jmonkeyplatform"

and I get this:
/home/lorenzo/jmonkeyplatform/bin/jmonkeyplatform: 11: /home/lorenzo/jmonkeyplatform/bin/../etc/jmonkeyplatform.conf: /home/lorenzo/Desktop/Java/jdk1.7.0_05: Permission denied

I think it's an Ubuntu related issue, but hopefully someone can help me?

(Not sure it's the right place to ask for help, sorry if it isn't)

I haven’t used linux much, but looks like you don’t have JDK installed, or it doesn’t know here jdk is, just go to the link the ide gave you and install jdk using those commands.

or maybe you already did that? thats why you’re asking help? in that case please give us more information

I downloaded the jdk and extracted it here:


Since when I run jmp in terminal I get the message /home/lorenzo/jmonkeyplatform/bin/jmonkeyplatform: 11: /home/lorenzo/jmonkeyplatform/bin/…/etc/jmonkeyplatform.conf: /home/lorenzo/Desktop/Java/jdk1.7.0_05: Permission denied

I think that the problem is in the folder permissions, maybe? I tried to change them but no results.

Anyway, for now I’m using Eclipse. Is there a big difference?

No double posting :x