This is my desperate hour- Help me with Ogre3D!

Hello all.

I’ve had a bad day as it stands, but what just happened really tops it all off. I was installing OgreXML via jmonkey, and I accidentally did not select the scripts folder. It then gave me a message that looked as though it had been successful. I checked the add-ons in blender just to see if it worked, but I knew it didn’t, and I was right. So then I went back to JMonkey and selected the scripts folder this time when I tried to install it. I got the following error message:

Error: C:\Program Files\BlenderFoundation\Blender\2.67\scripts\ is denied)

Please help me. I wanted so much to make a game this summer. I already tried uninstalling and re-installing jmonkey. I am at a complete loss of what to do.

Thank you.

There is no working exporter for blender 2.67. the last supported is blender 2.66.
go there
in the source tab download “”.
then install blender 2.66, copy the file in the scripts forder in the blender 2.66 installation folder.

Then in blender go to File/User Preferences in the search box type “ogre”, you should have 1 plugin entry.
Check this entry and close the dialog box.
Now go to File/Export/Ogre 3D (.scene and.mesh)

1 Like

Or (unless you are doing IK animations) you can just directly import the blend files, which works very well. Just drop the blend file into your assets folder, right click on it and select convert to j3o.

Thank you for giving me some advice. I’m going to try out your suggestions now and tell you how it turns out. Please keep posted on this thread to see if I encounter additional problems, because I probably will. If I use .blend files and then convert them within jmonkey, will the animation be included or only the model itself? And how should I just “drop the file in there”?

On a side note, is it possible to import from blender with textures? I know that the answer is probably no, but you can understand why I ask the question. Thank you all so much for taking the time to help me out!

EDIT: I dropped the blend file inside of the folder, and it only gave me the object, as I figured would happen. So no animation without Ogre I take it?

EDIT2: I installed the exact file that the first poster listed, installed .66, and loaded the file into the addons folder within the scripts folder, and I still don’t see anything when I type “ogre” into the addons in the user preferences in blender. Was I supposed to just put it on top of the scripts folder?

EDIT3: I went to install from file under addons and found the and clicked install. I got an error message. I am now completely lost as to what I should be doing.

EDIT4: I got a version of ogre working and I was really happy, but then I saw that it only exports .scenes and .meshes. I tried using the one that the first poster gave me but when I tried to install it in blender I got an error message. SOMEONE PLEASE HELP ME! YOU HAVE NO IDEA HOW MUCH THIS FRUSTRATES ME!

You can import animations from blender, so long as its plain skeletal animations with no inverse kinematics.

I’ve done it and it works well.

Textures will import from blender as well, but other material settings aren’t really transferable. Personally I prefer to create the materials inside jme anyway, but that’s just me.

Could you give me a step by step on how to import the animation with blender only? Ogre is giving me a really hard time. I sort of got it working, but all I get when I export is the .scene. I’m new to this, and I can’t seem to find any good step-by-steps anywhere. I read "creating assets in Blender3D but it didn’t help me with my specific problem. Thank you.

Literally you just right click “Convert to .j3o”, there’s not much more steps involved than that.

If that doesn’t work then try nightly, as vanilla RC2 is becoming quite ancient now ^^ (you will probs have to build it yourself or use the built nightly .jars as updating via the jMEDK is still broke).

Also post your .blend file and we can look at it.

  1. Create skeletal animation in blender (making sure all the limitations as mentioned here and in the docs are followed).

  2. Add blend file to jme project assets

  3. right click->convert to j3o

  4. Profit.

4.1 Open file in scene explorer (the tree view, not just the graphical view) and you can see the structure…it should have nodes, geometries and either 1 or 2 animation controls.

I have two different animations that I made. They are titled run and idle, and I have them open on the same line in the NLA editor. Do I use these names once I have loaded them into jmonkey?

I certainly won’t be ^^ im off to bed

I load the blender file in, click convert to j3o binary, and then nothing happens after that. Nothing at all. At the top of the scenecomposer screen, however I do see taht it says Models/BlenderFiles/Character.j3o, but I don’t see anything. Also a file didn’t pop up under the character.blend at the left hand side of the screen. How do I see if all of this worked and, more importantly, how do I see my animation?

EDIT: There is no j30 and an error message pops up. Unexpected exception: relative path is outside asset manager root. Know what this is and how to fix it? I am about ready to give up on the entire game because of this ridiculousness.

EDIT2: I’ve finally fixed this whole problem up. I loaded the blender file right in. I have but one more question: How do I see the animations? Thanks.


u can see the animations the scene composer under animcontrol .if you still interested in exporting ogre models from blender, i posted a link to a pdf tutorial on to do so which worked fine for me,check for it under the import assets troubleshooter

This is all the information you need to import animations into blender:

When using blender2.67b or similar. On the Ogre exporting options you must check the box “Independent Animations”.

After following these steps please come back if you have any more questions.

I have manged to get the ogre mesh and skeleton files into jmonkey. Thank you all so much for helping!

I have one more question. I have textured my character within blender, and he has multiple textures. Is there any way to get the material file this way?

Thanks so much

Checkbox seperate materials in blender ,or in the scene composer ,select a geometry ,under material in properties select create ,then you can modify the material

Well, I unchecked separate materials, and I did get a single material file, and then I imported it. But when I double clicked the mesh, it said that it couldn’t find the material file, even though they had the same name! So then I imported it manually, and then it did work, but nothing showed up in the SceneComposer after that! My character is there, but he is invisible! There aren’t any lamps! When I go to my .material file (the code for it within Jmonkey) it says at the top “material missing_material”. That might have something to do with it. But I don’t understand why it won’t work!

EDIT: I clicked the lightbulb above scene composer (duh) and my character showed up. But the texture is… strange. He has red and white spots everywhere. Not red as in, there is no material. He definitely looks like he has a material, just not the material that I want him to have.