Transparent glsurface view in Android 4.3 does not work

Today after updating my S3 to Android 4.3 I suddenly had the problem that my glsurface view was not rendering correctly anymore. I set it to be transparent like this:

[java]public class JmeTestActivity extends AndroidHarness {

public JmeTestActivity() {
	appClass = "exampleApps.MyTestApp";
	screenOrientation = ActivityInfo.SCREEN_ORIENTATION_LANDSCAPE;
	eglAlphaBits = 8;


Setting the apha bits to something else then 0 will cause the glsurface view to mirror everything and have strange graphics errors on the S3. might this be a s3 bug or is it something which happens on any Android 4.3 device?

Here i made a screenshot:

Can anyone reproduce this on their phone?

Can’t test that right now.
Were you able to test it on other devices/ os versions?

@nehon said: Can't test that right now. Were you able to test it on other devices/ os versions?

The important thing is that it worked on the same device before I updated to 4.3 (before it was 4.1.2 ) I would be interested if other devices with 4.3 have the same problem or if it is only a Samsung S3 problem)

I now also tested on a Nexus 4 android 4.3 (with cyanogenMod 10.2) and there the graphic errors do not appear. I also tested with a jMonkey version from August 2013, there the error still appears on the Samsung S3 with 4.3. So my guess now is that this happens only on the new Samsung devices. Can someone who has a Samsung S3 with 4.3 installed confirm this? And does someone have an idea what Samsung fucked up there? Might this also cause other problems?

and i now tested also with a samsung s4 also with android 4.3 and there it works normally. i realy hope that this is then just a one device related bug only for the samsung s3, so it would be nice if you could test the example setup up there on your phone, if there is a problem you will directly see it :wink:

Ok now i installed cyanogenmod on the S3 hoping to have at least a working test device again and its now Android 4.4.2 but still the same error. So maybe its not Samsungs fault but a concrete problem of the hardware with the lastest Android versions (>=4.3) ?