Trouble Getting Started with FengGUI

Hi guys,

I'm tring to use FengGUI, but I've encountered a few problems.

Here's what I've done:

1-I've downloaded FengGUI jars from

2-I've taken the FengJMEInputHandler (the new version) and FengJME from this site.

3-I've rectified FengJME mistake

4-I've tried to run FengJME

The problem is that the only result I get is this error:

8-mag-2009 10.04.46 class proveFengGUI.FengJME start()
GRAVE: Exception in game loop
java.lang.NoClassDefFoundError: org/lwjgl/opengl/glu/GLU
at org.fenggui.binding.render.lwjgl.LWJGLOpenGL.setOrtho2D(
at org.fenggui.Display.display(
at proveFengGUI.FengJME.render(
at proveFengGUI.FengJME.main(
Caused by: java.lang.ClassNotFoundException: org.lwjgl.opengl.glu.GLU
at$ Source)
at Method)
at Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
... 5 more

Can anyone help me??

That would be the link:

edit …i'm a bit confused:

FengGUI just released a new version, but seems to still use lwjgl 1.x.

Even tho the svn log says its updated to lwjgl 2.1.

Core-Dump said:

FengGUI just released a new version, but seems to still use lwjgl 1.x.
Even tho the svn log says its updated to lwjgl 2.1.

Looking at the changes it should now work with lwjgl 2.1, but lwjgl is no longer included in the thrid party lib folder.

After a small change to the build.xml, it built fine with lwjgl  2.1.

I've uploaded the new FengGUI.jar to the jme-demos link above.

If i try to use the FengGUI.jar from sourceforge, i'm getting the same error as oxcutter.

Even tho that the current svn source uses org.lwjgl.util.glu.GLU and not org.lwjgl.opengl.glu.GLU.  :?

Sorry but I'm a total nooooob! ://

The FengGUI.jar you're talking about, I have to download it via SVN or by clicking on the link and then downloading it clicking "view raw files"??

I've tried the second one but I still get the same error! What do I have to do??

'view raw file' should work fine.

here is an alternative link

thx Core-Dump, now it run but I only see a window with a box…there's no gui…maybe it's my code that's wrong because of the change that I've done to make it run??

i dont really use FengGUI much, there are many issues when displaying FengGUI and 3d content at the same time with jME.

I use FengGUI only for a very simple Menu

i’d actually suggest looking into GBUI or another gui library

Hm using a own Renderpass for Fenggui, and applying a default Renderstate before useing it seems to be all that is needed. at least for me it seems to work fine.

Hi guys,

I am using FengGUI with JME2 but I am getting this exception

java.lang.ClassNotFoundException: org.lwjgl.opengl.glu.GLU

Is there a version of FengGUI that works with JME2?


last time i worked with it, FengGUI used an older version of lwjgl, than jME, so you had to create your FengGUI jar yourself.

you can try this one, it should work with jme2:

Thanks a lot,

I tried that, and it seems to work. I have to fix some errors though. Are there substitutes for MessageWindow or for TextView?

i have no clue, better ask on the fenggui forum