Trouble importing material from blender

Hi Guys
Ive just been banging my head against importing models from blender for days, I went down to ogre export route, but no matter what i do my animations distort the model…
I have got animations working when i use the .blend file file directly but i can’t seem to get the texture to show up… I have followed the guides (i far as i can tell), and i did save the image and model directly into the jme3 models folder…
the model just looks like its got a material but no reference to the image

I have put my model here.

i right click convert to j3o. and I’m loading it
player = (Node)assetManager.loadModel(“Models/Soldier/allied1.j3o”);

And on a side note i would seriously consider taking some kind of guided tutorial from someone as long as its reasonably priced :slight_smile:


There is 0 things wrong with your model.

There is one thing that is likely wrong with the model. I’ll check it and get back to you. I think its your floating root bone!

After that, I’m not sure how much of a difference it makes but you either provided a model without the NLA tracks sorted or your NLA tracks arent sorted. This part I’m not sure about since I always sort out my NLA tracks.

But I do believe its your floating root bone that makes 0 difference if its there or not.

1 Like

Problem: It seems something threw your origins out of sync maybe that last bone was attached from an odd position, whatever did it. Although I don’t think the Bone matters, since you linked it into the bone hierarchy anyway… I worked around that.

Solution:Select your main armature group, and CTRL+A -> apply location, then select your mesh and CTRL+A -> apply location.

Next step: Sort your animations into NLA track/s.

1 Like

I checked into your texture problem. I don’t know much about the extent of blender->ogre->jme importing cycles nodes settings, but I think that’s where you are getting stuck, as your node setting was on cycles.

I make a lot of my materials settings in JME, so I can’t say for sure if it can accept blender mat nodes through ogre import.

So to simplify things:

Up top where Cycles Render is, toggle that to Blender Render.

From there go to the material setting and make it whatever you want, it does have some impact when you import.

With the material you want to texture selected, click the little textures tab next to it and set your texture(s) diffuse spec normals whatever you got. Since I usually end up tweaking my material in JME, I dont care as much what i stick in here, as long I have a proper UV set up for the mesh(es).

Do not forget to map it to UV if you set something

That’s probably all you need to make it work.

1 Like

its alive!!!

thanks so much
the learning curve has been steep…

1 Like

as i said earlier if your interested in giving me a short tutorial for a reasonable price. id be interested…
thanks again

Hi All

Ok it appears i was too hasty in claiming everything is “working” while jme3 now applies the texture i say… it seems to be alined or scaled incorrectly. The texture looks correct on blender but not once imported to jme3.

Interestingly when i use the model imported tool it says the texture has been flipped and mini mapped. (although in my program i just right click convert to j3o)
I did try to flip the image around, while it changed how it looks in game it still was not correct…

should i be scaling the image?
perhaps i applied it wrong in blender
i have included my model here
many thanks

From the file supplied:

you had Use shader nodes to render the material set

its under materials next to the data/object toggle under the material selection.

I assume JME is unhappy with this import setup and checking blender’s default UV map settings, which is usually whatever blender sets.

It should map right if you unset this option, then go to the texture area and set under: Mapping: Coordinate: UV

Maybe there is a way to import nodes with the map set up. Since I just make all my materials in JME, I never attempted to do so.

1 Like