Trouble importing textures from blender [solved]

I sucessfully made a couple of couple of models before beta which had the UV textures on fine and now I cant seem to get textures to appear in JME.



so this is my test .blend file

http://i1005.photobucket.com/albums/af179/SmallishSteve/pic1.png

:slight_smile: it all looks lovely and textured. I have packed the image into the blend file.

Then after importing into JME

http://i1005.photobucket.com/albums/af179/SmallishSteve/pic2.png

:frowning: There is no texture.



This has happend on quite a few different models. Am I missing a step somewhere?

Thanks

Make sure you’ve saved your textures to files, and the .blend file is together the textures in same asset folder.

Is this what you mean? I put the png file i used for the texture in blender in the same asset folder as the .blend file.

http://i1005.photobucket.com/albums/af179/SmallishSteve/pic3.png

This picture also shows the console output when I view the model

I did have previous success packing the texture into the blend file, so i didnt need a separate png file.

Just add the texture later using a j3m, the uv coords are in the mesh anyway.

SUCCESS! thank you very much. its also nice getting all the cool options j3ms have. I do have to flip the texture, which is random but not a problem

@stevie said:
I do have to flip the texture, which is random but not a problem

No thats not random, thats always like that when exporting from blender.