Trouble with bone animation.. Importing from blender in to jmonkey

My friend and I are new to making games. He’s learning to use blender and I’m learning to use jMonkey.

He’s created a character with bones. and he tells me it animates fine within blender. However upon importing it into jmonkey and activating the “run” animation it will just totally mess up.

I beleive the issue is because there is this weird random extra bone with no label in the SkeletonControl

Screens shot of it in jmonkey: (I highlighted the weird bone in yellow)

My friend tells me he does not see this weird bone in blender. This is a screen shot of his screen with it loaded in blonder:

Does anyone know what might be causing this extra bone to be showing up, and how we can get rid of it? (assuming this is the problem)

What blender/jME SDK version are you using?

Do you see any error messages when importing?

Have you tried the blender2ogre converter to see if the same issue persists?

Did you make sure to follow all of these correctly?:

Blender version: 2.58
jMonkey version: 3.0RC2

I didn’t even think to look at the output window. but there seems to be errors (all the messages about weights are in red) I’m not sure what it means though :

I haven’t tried blender2ogre yet. (working on trying to get that installed now)

My friend used that guide when making the skeleton (in an attempt to make sure it would import correctly)

ok, those are mainly warnings and not really that important.

I just did some tests, and noticed that a model of mine with animations imported from the Blender importer has the same “empty” bone as you, BUT the animations are still playing correctly.
An animation exported with blender2ogre does not have this extra empty bone.

So i think there is something else wrong with your model, double check the guide again.

You should try the Blender importer from a nightly build. The importer in recent nightly builds of JME3 is much better than in 3.0RC2.

Try to apply the transforms on both the model and the armature in blender before exporting.

Your Blender model has assigned more than 4 bones to each vertex. To fix it, select your model in OBJECT mode, switch to WEIGHT paint, look to the left panel and look for limit vertices or something like that, slide the slider to 4, and check all deform weights :slight_smile: