Trouble with running jMP

I am trying to get started a little bit with jme3 and jMP, however, when I run jMP, once it finishes loading it tends to go rather sluggishly, and NetBeans keeps repeating this error in the output:

java.lang.IllegalStateException: Function is not supported

        at org.lwjgl.BufferChecks.checkFunctionAddress(

        at org.lwjgl.opengl.GL20.glCreateProgram(

        at com.jme3.renderer.lwjgl.LwjglRenderer.updateShaderData(

        at com.jme3.renderer.lwjgl.LwjglRenderer.setShader(

        at com.jme3.material.Material.render(

        at com.jme3.renderer.RenderManager.renderGeometry(

        at com.jme3.renderer.queue.RenderQueue.renderGeometryList(

        at com.jme3.renderer.queue.RenderQueue.renderQueue(

        at com.jme3.renderer.RenderManager.flushQueue(

        at com.jme3.renderer.RenderManager.renderViewPort(

        at com.jme3.renderer.RenderManager.render(

        at com.jme3.gde.core.scene.SceneApplication.update(

        at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(

        at com.jme3.system.lwjgl.LwjglCanvas.runLoop(



Does anyone know offhand what that means, or more importantly, how to fix it?  I get this same error, I think, when I try to run many of the jme3 test programs, so it might not necessarily be a jMP specific problem.  I recently wiped this computer clean, so I am wondering if I might be missing a file somewhere…?

Thanks for any advice!

Did you install the latest graphics drivers and is your card opengl2 compatible?

I wonder how could it get to that part of the code? It should have crashed at the OpenGL2 check…

Bad video card drivers strike back…

I can’t launch too.

and here is the logs

Flameberge said:

I can't launch too.
and here is the logs

Do you have a OpenGL card? Maybe try using the Sun JDK instead of the OpenJDK.
Flameberge said:

I can't launch too.

and here is the logs

It says the error is in, on function XF86DRIQueryExtension.
OpenGL should never have a native crash, no matter what. So this is either a bad driver or an operating system issue.

O_o seems like i have to develop in WinOS…

I'm not a good pro in Linux, it's a bit hard to repair that thing for me :|+